summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-08 23:33:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:35 +0100
commit6a2f1863e7707fc958efa417285161c7eced4904 (patch)
tree11f9d99e94126c25a895477e253a58608edd2fc1
parentc647bd42a3f7e03b1eb2e4d196c79de3be237f3b (diff)
downloadguix-6a2f1863e7707fc958efa417285161c7eced4904.tar.gz
gnu: Add python-pytest-nunit.
* gnu/packages/check.scm (python-pytest-nunit): New variable.

Change-Id: Ic67c973460f09b15bf683f70040a3f5e4381108d
-rw-r--r--gnu/packages/check.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b475aea8ae..4de5b1c0d4 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -24,7 +24,7 @@
 ;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2015, 2017, 2018, 2020, 2021, 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2018, 2020, 2021, 2023, 2024 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016-2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2017, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@@ -1480,6 +1480,27 @@ from a .env file before running tests.")
 contacting the real http server.")
     (license license:expat)))
 
+(define-public python-pytest-nunit
+  (package
+    (name "python-pytest-nunit")
+    (version "1.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-nunit" version))
+       (sha256
+        (base32 "1gw3a33myq9yncjixs3kkcrr1xkjzvvf3xk6x955p3i79wlwkswx"))))
+    (build-system pyproject-build-system)
+    (arguments (list #:tests? #false)) ;no tests included
+    (propagated-inputs (list python-attrs python-pytest))
+    (native-inputs (list python-pytest python-pytest-cov python-xmlschema))
+    (home-page "https://github.com/pytest-dev/pytest-nunit")
+    (synopsis "Pytest plugin for generating NUnit3 test result XML output")
+    (description
+     "This package provides a pytest plugin for generating NUnit3 test result
+XML output")
+    (license license:expat)))
+
 (define-public python-pytest-param-files
   (package
     (name "python-pytest-param-files")