summary refs log tree commit diff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2022-08-25 20:46:59 +0200
committerMarius Bakke <marius@gnu.org>2022-08-29 18:22:59 +0200
commit6a31fb6e7b2bc6daba973d440ea4480d57ee6597 (patch)
tree39519e81252f5ab03f2beac0d1661f52342ad61a
parent5831155175614726685edab7efa60ce48e4da1f5 (diff)
downloadguix-6a31fb6e7b2bc6daba973d440ea4480d57ee6597.tar.gz
gnu: snakemake-6: Convert dependencies to propagated-inputs
* gnu/packages/python-xyz.scm (snakemake-6)[inputs]: Change to ...
[propagated-inputs]: ... this, to ensure that "python -m snakemake"
works (because snakemake uses it internally).

Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0accf918ee..a8248e3ec8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9688,7 +9688,7 @@ Python style, together with a fast and comfortable execution environment.")
                ;; because there are no AWS credentials.
                (delete-file "tests/test_tibanna.py")
                (invoke "pytest")))))))
-    (inputs
+    (propagated-inputs
      (list python-appdirs
            python-configargparse
            python-connection-pool