summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-10 09:37:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-10 09:37:28 +0300
commit6ae59e7d792c8339a5f6df8bc4eca42ab8ca7457 (patch)
tree0967d8089f15d76981f982e167ab56bcca7504d8
parente7971cb430d45f9ad8fcc0fe5bd88e1b863c5047 (diff)
downloadguix-6ae59e7d792c8339a5f6df8bc4eca42ab8ca7457.tar.gz
gnu: kdeconnect: Fix build.
* gnu/packages/kde.scm (kdeconnect)[arguments]: Replace custom
'extend-CPLUS_INCLUDE_PATH with 'adjust-include-header to fix finding
all header files.
-rw-r--r--gnu/packages/kde.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 3fa15f9bf5..bcf7146782 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -715,15 +715,13 @@ different notification systems.")
     (arguments
      `(#:configure-flags '("-DBUILD_TESTING=ON"
                            "-DKDE_INSTALL_LIBEXECDIR=libexec")
-       #:phases (modify-phases %standard-phases
-                  (add-after 'set-paths 'extend-CPLUS_INCLUDE_PATH
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      ;; FIXME: <kcmutils_version.h> is not found during one
-                      ;; of the compilation steps without this hack.
-                      (setenv "CPLUS_INCLUDE_PATH"
-                              (string-append
-                               (search-input-directory inputs "include/KF5")
-                               ":" (or (getenv "CPLUS_INCLUDE_PATH") ""))))))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'adjust-include-header
+           (lambda _
+             (substitute* "plugins/runcommand/runcommandplugin.cpp"
+               (("<kcmutils_version.h>")
+                "<KF5/kcmutils_version.h>")))))
        #:tests? #f)) ; tests fail hard in our build environment
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)