summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-26 11:03:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-02-28 10:53:35 +0200
commit6b59fc1020174e8157c9f6ab78fdddd54efa3eb2 (patch)
tree92c46747d502accaf9c75629c8079390dd99645b
parent9579118922a344a6803deb4bc3136b0387e52854 (diff)
downloadguix-6b59fc1020174e8157c9f6ab78fdddd54efa3eb2.tar.gz
gnu: Add python-backports-abc.
* gnu/packages/python.scm (python-backports-abc): New variable.
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2441220901..3cd02c112f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4990,6 +4990,31 @@ connection to each user.")
           ,python2-backport-ssl-match-hostname)
          ,@(package-inputs tornado))))))
 
+;; the python- version can be removed with python-3.5
+(define-public python-backports-abc
+  (package
+    (name "python-backports-abc")
+      (version "0.4")
+      (source
+        (origin
+          (method url-fetch)
+          (uri (pypi-uri "backports_abc" version))
+          (sha256
+           (base32
+            "19fh75lni9pb673n2fn505m1rckm0af0szcv5xx1qm1xpa940glb"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "https://github.com/cython/backports_abc")
+    (synopsis "Backport of additions to the 'collections.abc' module.")
+    (description
+     "Python-backports-abc provides a backport of additions to the
+'collections.abc' module in Python-3.5.")
+    (license psfl)))
+
+(define-public python2-backports-abc
+  (package-with-python2 python-backports-abc))
+
 (define-public python-waf
   (package
     (name "python-waf")