summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-03-18 19:40:03 +0100
committerLudovic Courtès <ludo@gnu.org>2016-03-18 19:42:00 +0100
commit6cbc8d5766e11cb6fefb7c281d6d6854793a3d24 (patch)
tree8940ef11d9e82fe7bec5616b3942d834b37850ff
parentc510cbb4ecb270ca3edf282c6769aa2bfb144822 (diff)
downloadguix-6cbc8d5766e11cb6fefb7c281d6d6854793a3d24.tar.gz
gnu: gnome: Disable hardware acceleration check via 'gnome.desktop'.
* gnu/packages/gnome.scm (gnome-session)[arguments]: Add
'disable-hardware-acceleration-check' phase.
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b998cc36e8..e5d62eacd6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3820,7 +3820,18 @@ such as gzip tarballs.")
                    (out  (assoc-ref outputs "out")))
                (wrap-program (string-append out "/bin/gnome-session")
                  `("PATH" ":" prefix (,(string-append glib "/bin"))))
+               #t)))
+         (add-after 'install 'disable-hardware-acceleration-check
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Do not abort if hardware acceleration is missing.  This allows
+             ;; GNOME to run in QEMU and on low-end devices.
+             (let ((out (assoc-ref outputs "out")))
+               (substitute* (string-append out
+                                           "/share/xsessions/gnome.desktop")
+                 (("gnome-session")
+                  "gnome-session --disable-acceleration-check"))
                #t))))
+
        #:configure-flags
        '("--enable-elogind")))
     (build-system glib-or-gtk-build-system)