summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-30 00:06:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:38 -0400
commit6ce1f74c9a91de93951a480baa2b33d3d2ce6317 (patch)
tree0590e4109d15aa693fc1f17a3871e6d5444a3959
parentf283842e3c9125b7d8f1d356509e6c92d810cd4d (diff)
downloadguix-6ce1f74c9a91de93951a480baa2b33d3d2ce6317.tar.gz
gnu: Remove python2-sphinx.
* gnu/packages/sphinx.scm (python2-sphinx): Delete variable.
(python-sphinx)[properties]: Delete field.
-rw-r--r--gnu/packages/sphinx.scm49
1 files changed, 1 insertions, 48 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 93f174217a..2c4eb09d04 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -146,54 +146,7 @@
     (description "Sphinx is a tool that makes it easy to create documentation
 for Python projects or other documents consisting of multiple reStructuredText
 sources.")
-    (license license:bsd-2)
-    (properties `((python2-variant . ,(delay python2-sphinx))))))
-
-;; Sphinx 2 does not support Python 2, so we stick with this older version here.
-(define-public python2-sphinx
-  (let ((base (package-with-python2 (strip-python2-variant python-sphinx))))
-    (package
-      (inherit base)
-      (version "1.7.7")
-      (source (origin
-                (method url-fetch)
-                (uri (pypi-uri "Sphinx" version))
-                (sha256
-                 (base32
-                  "0pkkbfj7cl157q550gcs45am5y78ps0h7q6455d64s1zmw01jlvi"))))
-      (arguments
-       (substitute-keyword-arguments (package-arguments base)
-         ((#:phases phases)
-          `(modify-phases ,phases
-             (add-before 'check 'disable-broken-tests
-               (lambda _
-                 (for-each delete-file
-                           ;; These tests are broken when using Python2:
-                           ;; <https://github.com/sphinx-doc/sphinx/issues/4710>.
-                           '("tests/test_api_translator.py"
-                             "tests/test_setup_command.py"
-                             ;; Websupport is provided by a separate package
-                             "tests/test_websupport.py"
-                             ;; This one fails for unknown reasons.
-                             "tests/test_correct_year.py"))))))))
-      (native-inputs (modify-inputs (package-native-inputs base)
-                       (prepend python2-mock python2-enum34)))
-      ;; Sphinx 2 has some dependencies that do not support Python 2, so
-      ;; we keep our own propagated-inputs here instead of inheriting.
-      (propagated-inputs
-       (list python2-pytz
-             python2-typing
-             python2-imagesize
-             python2-sphinx-alabaster-theme
-             python2-babel
-             python2-snowballstemmer
-             python2-docutils-0.14
-             python2-jinja2
-             python2-packaging
-             python2-pygments
-             python2-requests
-             python2-six
-             python2-sphinxcontrib-websupport)))))
+    (license license:bsd-2)))
 
 (define-public python-sphinxcontrib-apidoc
   (package