summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-01-18 16:37:41 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-18 16:37:41 +0100
commit6d7b26a39faf42c37f15dc64a30a77e5e194ea23 (patch)
treee518ad563007facd2ebcd0383bdd398901fe532a
parent8102cf0b37e100f760d25b500cf91ed38928615c (diff)
downloadguix-6d7b26a39faf42c37f15dc64a30a77e5e194ea23.tar.gz
gnu: bootstrap: 'package-with-bootstrap-guile' uses 'eq?' memoization.
* gnu/packages/bootstrap.scm (package-with-bootstrap-guile): Use
'mlambdaq'.
-rw-r--r--gnu/packages/bootstrap.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index d1b03eb882..b02737cb7c 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -137,7 +137,7 @@ successful, or false to signal an error."
     (license gpl3+)))
 
 (define package-with-bootstrap-guile
-  (mlambda (p)
+  (mlambdaq (p)
     "Return a variant of P such that all its origins are fetched with
 %BOOTSTRAP-GUILE."
     (define rewritten-input