summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:22:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:37 +0200
commit6d8136511c175857e037662c10ecfe545bd48b86 (patch)
tree2ab83dc52004dc4bbfd3636d1cc6c43366b6ad64
parent683b55ba8bc55a11d6df0c788fd526133c2c046b (diff)
downloadguix-6d8136511c175857e037662c10ecfe545bd48b86.tar.gz
gnu: Add texlive-pst-intersect.
* gnu/packages/tex.scm (texlive-pst-intersect): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fe37468836..8c7fb6ba60 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33258,6 +33258,28 @@ beginner, providing macro commands that convert natural mathematical
 expressions to PostScript syntax.")
     (license license:lppl)))
 
+(define-public texlive-pst-intersect
+  (package
+    (name "texlive-pst-intersect")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/pst-intersect/"
+                   "dvips/pst-intersect/"
+                   "source/latex/pst-intersect/"
+                   "tex/generic/pst-intersect/"
+                   "tex/latex/pst-intersect/")
+             (base32
+              "157yqj923kikm8abiv3giyf9rrr6cw0jwqj37ri5ya5iyxlfvmmv")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-intersect")
+    (synopsis "Compute intersections of arbitrary curves")
+    (description
+     "The package computes the intersections between arbitrary PostScript
+paths or Bezier curves, using the Bezier clipping algorithm.")
+    (license license:lppl)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")