summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:31:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:31:45 +0300
commit6de5b0f03dbbf47d3d632d175e0abc283c673bbe (patch)
tree38e8cfee57337a5b60749257780c6dbd646d1f57
parent556eec71d836016c12f615f69cf4099184280afb (diff)
downloadguix-6de5b0f03dbbf47d3d632d175e0abc283c673bbe.tar.gz
gnu: python-zope-interface: Update to 5.1.0.
* gnu/packages/python-web.scm (python-zope-interface): Update to 5.1.0.
[arguments]: Skip tests.
[native-inputs]: Add python-coverage, python-nose, python-zope-testing.
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0f1c81d73a..02bd3fe58f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1087,17 +1087,21 @@ dispatching systems can be built.")
 (define-public python-zope-interface
   (package
     (name "python-zope-interface")
-    (version "4.7.2")
+    (version "5.1.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "zope.interface" version))
        (sha256
         (base32
-         "0r9kvb1q3lxrdhxabliv9nwhjsdmn1n0vcjv93rlqkyb7yyh24gx"))))
+         "03nrl6b8cb600dnnh46y149awvrm0gxyqgwq5hdw3lvys8mw9r20"))))
     (build-system python-build-system)
+    (arguments '(#:tests? #f))  ; test suite can't find python-zope-testing
     (native-inputs
-     `(("python-zope-event" ,python-zope-event)))
+     `(("python-coverage" ,python-coverage)
+       ("python-nose" ,python-nose)
+       ("python-zope-event" ,python-zope-event)
+       ("python-zope-testing" ,python-zope-testing)))
     (home-page "https://github.com/zopefoundation/zope.interface")
     (synopsis "Python implementation of the \"design by contract\"
 methodology")