summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-10 23:16:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-10 23:23:15 +0300
commit6dfa3e5d8553bfb811a1e93a3184a1ba8c7a4f4f (patch)
tree12db6d93785d13140e01dabce731ee0753cb1d4e
parent49cbc18334f2e90c03d2ed8f96f3bb8fa00725df (diff)
downloadguix-6dfa3e5d8553bfb811a1e93a3184a1ba8c7a4f4f.tar.gz
gnu: qpdf: Fix cross-building.
* gnu/packages/pdf.scm (qpdf)[arguments]: When cross-building add
configure-flags to set /dev/random and /dev/urandom as existing.
-rw-r--r--gnu/packages/pdf.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index dd1064bd6c..17637af0f6 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -910,7 +910,13 @@ line tools for batch rendering @command{pdfdraw}, rewriting files
               "0yw2cpw7ygfd6jlgpwbi8vsnvv9p55zxp9h17x77z2qq733pf8jx"))))
    (build-system gnu-build-system)
    (arguments
-    `(#:disallowed-references (,perl)
+    `(#:configure-flags '(,@(if (%current-target-system)
+                              ;; We cannot check for these devices
+                              ;; when cross compiling.
+                              `("ac_cv_file__dev_random=yes"
+                                "ac_cv_file__dev_urandom=yes")
+                              '()))
+      #:disallowed-references (,perl)
       #:phases
       (modify-phases %standard-phases
         (add-before 'configure 'patch-paths