summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-23 12:00:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-23 13:36:47 +0100
commit6e835cd380c040aefbf38959634022417b29eb5b (patch)
tree7f3bfd7690d548d2361eb915c2e67c46308abae3
parent994817bfdccc715dccfa96366fc286a80171a7e6 (diff)
downloadguix-6e835cd380c040aefbf38959634022417b29eb5b.tar.gz
gnu: Add r-scenic.
* gnu/packages/bioinformatics.scm (r-scenic): New variable.

Change-Id: Iff1f501a406ba1a12e49093a575e03facc98f303
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4198acecda..40a264fd61 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1100,6 +1100,43 @@ high-throughput sequence analysis.  The package is primarily useful to
 developers of other R packages who wish to make use of HTSlib.")
       (license license:lgpl2.0+))))
 
+(define-public r-scenic
+  (let ((commit "cedf8490a634da550cea2c831544e5f7f14467d2")
+        (revision "1"))
+    (package
+      (name "r-scenic")
+      (version (git-version "1.3.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/aertslab/SCENIC")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "17ai0q260hdqbvm1km1s5dw93pgz4f546ycfii57jyy9m9jka7r0"))))
+      (properties `((upstream-name . "SCENIC")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-aucell
+                               r-data-table
+                               r-dynamictreecut
+                               r-genie3
+                               r-ggrepel
+                               r-mixtools
+                               r-nmf
+                               r-rcistarget
+                               r-rtsne))
+      (native-inputs (list r-knitr))
+      (home-page "https://github.com/aertslab/SCENIC")
+      (synopsis
+       "SCENIC (Single Cell rEgulatory Network Inference and Clustering)")
+      (description "SCENIC (Single-cell regulatory network inference and
+clustering) is an R package to infer Gene Regulatory Networks and cell types
+from single-cell RNA-seq data.")
+      ;; As of commit cedf8490a634da550cea2c831544e5f7f14467d2 the license is
+      ;; GPLv3.
+      (license license:gpl3))))
+
 (define-public r-singlet
   (let ((commit "765a6c45081807a1522f0e8983e2417822a36f36")
         (revision "1"))