summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-09 18:50:16 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-09 18:55:47 +0200
commit6ec2e6b0c9bfae6be111f367079e57fd4d7ccdf5 (patch)
tree07dbe01e34291f4eed88ee310290bb2a4a67c5be
parente531172d11664557624edb821dd46a9d9237e3ad (diff)
downloadguix-6ec2e6b0c9bfae6be111f367079e57fd4d7ccdf5.tar.gz
gnu: skribilo: Propagate Guile dependencies.
Reported by Carlos Carleos <carleos@uniovi.es>.

* gnu/packages/skribilo.scm (skribilo)[inputs]: Move
  GUILE-READER/GUILE-2.0 and GUILE-LIB to...
  [propagated-inputs]: ... here.  New field.
-rw-r--r--gnu/packages/skribilo.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/skribilo.scm b/gnu/packages/skribilo.scm
index a8319f191a..e9c213cbb2 100644
--- a/gnu/packages/skribilo.scm
+++ b/gnu/packages/skribilo.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,11 +46,15 @@
        #:parallel-build? #f))
     ;; TODO: Add Ploticus.
     (inputs `(("guile" ,guile-2.0)
-              ("guile-reader" ,guile-reader/guile-2.0)
-              ("guile-lib" ,guile-lib)
               ("imagemagick" ,imagemagick)
               ("ghostscript" ,ghostscript)        ; for 'convert'
               ("lout" ,lout)))
+
+    ;; The 'skribilo' command needs them, and for people using Skribilo as a
+    ;; library, these inputs are needed as well.
+    (propagated-inputs `(("guile-reader" ,guile-reader/guile-2.0)
+                         ("guile-lib" ,guile-lib)))
+
     (home-page "http://www.nongnu.org/skribilo/")
     (synopsis "Document production tool written in Guile Scheme")
     (description