summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-24 15:58:57 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:21 +0000
commit6f4b1e4d79e0684312d776de3e99931c0162a650 (patch)
treefb2b9f777d128e6560cd4fb7d31ca733da330ed0
parent0ab1bfac668bda4559f3f35c34a12ce43cd75cba (diff)
downloadguix-6f4b1e4d79e0684312d776de3e99931c0162a650.tar.gz
gnu: gnome-calendar: Update to 40.2.
* gnu/packages/gnome.scm (gnome-calendar): Update to 40.2.
[source]: Fix the URI.
[inputs]: Add libhandy.
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9d34b40dba..73174924c8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9602,15 +9602,15 @@ desktop.  It supports world clock, stop watch, alarms, and count down timer.")
 (define-public gnome-calendar
   (package
     (name "gnome-calendar")
-    (version "3.34.2")
+    (version "40.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
-                                  (version-major+minor version) "/"
+                                  (version-major version) "/"
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1bnmd191044zn2kr6f5vg7sm5q59qf7z652awll1f7s6ahijr8rw"))))
+                "0czasxnmbw2zm21lmxam8qixacagciq3f815s809hn0f9byh2dwy"))))
     (build-system meson-build-system)
     (arguments
      '(#:glib-or-gtk? #t
@@ -9635,6 +9635,7 @@ desktop.  It supports world clock, stop watch, alarms, and count down timer.")
        ("libdazzle" ,libdazzle)
        ("libedataserverui" ,evolution-data-server)
        ("libgweather" ,libgweather)
+       ("libhandy" ,libhandy)
        ("geoclue" ,geoclue)))
     (propagated-inputs
      `(("evolution-data-server" ,evolution-data-server)))