summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:21:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:44 +0200
commit6fdc79c1210cb21179073e3d297cb73dc90c9c65 (patch)
treec5a3a61f85bd013de468a0b9e3c11d08480064ea
parentbb5263af7c3fc597da4b88ca5cef783403681921 (diff)
downloadguix-6fdc79c1210cb21179073e3d297cb73dc90c9c65.tar.gz
gnu: Add texlive-purifyeps.
* gnu/packages/tex.scm (texlive-purifyeps): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4cda7c7159..c1ac7d3093 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3200,6 +3200,36 @@ making the file suitable for processing by @command{pkfix}.
 does require the user to verify and, if needed, correct its decisions.")
     (license license:lppl1.3c)))
 
+(define-public texlive-purifyeps
+  (package
+    (name "texlive-purifyeps")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/purifyeps.1"
+                   "doc/man/man1/purifyeps.man1.pdf"
+                   "doc/support/purifyeps/"
+                   "scripts/purifyeps/")
+             (base32
+              "0523kgilwd142a43fw1r406rn8ck67hp78aqhsws931glf7j9y8p")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "purifyeps")))
+    (inputs (list perl))
+    (home-page "https://ctan.org/pkg/purifyeps")
+    (synopsis "Make EPS work with both LaTeX/dvips and pdfLaTeX")
+    (description
+     "While pdfLaTeX has a number of nice features, its primary shortcoming
+relative to standard LaTeX+dvips is that it is unable to read ordinary
+Encapsulated PostScript (EPS) files, the most common graphics format in the
+LaTeX world.  Purifyeps converts EPS files into a purified form that can be
+read by both LaTeX+dvips and pdfLaTeX.  The trick is that the standard LaTeX2e
+graphics packages can parse Metapost-produced EPS directly.  Hence,
+@command{purifyeps} need only convert an arbitrary EPS file into the same
+stylized format that Metapost outputs.")
+    (license license:lppl)))
+
+
 (define-public texlive-tex-ini-files
   (package
     (name "texlive-tex-ini-files")