summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-27 20:36:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-27 20:45:20 +0200
commit711a2f0611ec6386f43039704f2a97ba6640baa1 (patch)
tree2d9c14f6ddbc139ed1eb217ac8f2d617b710d629
parentc4568c5c647946b4276975d6b3c4fbef20445f1c (diff)
downloadguix-711a2f0611ec6386f43039704f2a97ba6640baa1.tar.gz
gnu: Add r-performance.
* gnu/packages/cran.scm (r-performance): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ad110b7e7d..474ef8e524 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7855,6 +7855,33 @@ Density Interval} (HDI), and indices used for null-hypothesis testing (such as
 ROPE percentage and pd).")
     (license license:gpl3)))
 
+(define-public r-performance
+  (package
+    (name "r-performance")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "performance" version))
+       (sha256
+        (base32
+         "19lfx25hkavzbycrh6hq4v24a0dz4s60ryq6jyihjlxgrb9g7cnw"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bayestestr" ,r-bayestestr)
+       ("r-insight" ,r-insight)))
+    (home-page "https://easystats.github.io/performance/")
+    (synopsis "Assessment of regression models performance")
+    (description
+     "This package provides utilities for computing measures to assess model
+quality, which are not directly provided by R's @code{base} or @code{stats}
+packages.  These include e.g. measures like r-squared, intraclass correlation
+coefficient, root mean squared error or functions to check models for
+overdispersion, singularity or zero-inflation and more.  Functions apply to a
+large variety of regression models, including generalized linear models, mixed
+effects models and Bayesian models.")
+    (license license:gpl3)))
+
 (define-public r-ggeffects
   (package
     (name "r-ggeffects")