summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:58:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:21 +0200
commit713ce9c39ce1c706257c6772491debd4f9ad4e99 (patch)
treed54e4be5243baa6da5339345a65ad2e2df026f5f
parentd9a1659008d36f5eba169b5b8a7bd9dc76e53e81 (diff)
downloadguix-713ce9c39ce1c706257c6772491debd4f9ad4e99.tar.gz
gnu: Add texlive-program.
* gnu/packages/tex.scm (texlive-program): New variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index da44e88646..e8c155de68 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93011,6 +93011,24 @@ solutions may appear in a different section of the same document as the
 problems they cover.")
     (license license:lppl)))
 
+(define-public texlive-program
+  (package
+    (name "texlive-program")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/program/" "tex/latex/program/")
+             (base32
+              "1icg7zv74g1q0rvg5vsmri1m17n87wmazgvy9brp3dmincsvg1jd")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/program")
+    (synopsis "Typesetting programs and algorithms")
+    (description
+     "The main offering is a @code{program} environment; a @code{programbox}
+environment is available for fragments that must not break with the pages.")
+    (license license:gpl3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar