summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-26 09:11:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-26 09:11:56 +0300
commit713dca1399cda2439af75989510f86718741a4ff (patch)
treeb76c91a408236785ac35d5256df2b76381cde68e
parentf76ef3f7593145efa6fdb5f26b2258043e14bad7 (diff)
downloadguix-713dca1399cda2439af75989510f86718741a4ff.tar.gz
gnu: toot: Update to 0.38.1.
* gnu/packages/mastodon.scm (toot): Update to 0.38.1.
[inputs]: Add python-tomlkit.
-rw-r--r--gnu/packages/mastodon.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index aa20975597..0aa88d3518 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -47,13 +47,13 @@
 (define-public toot
   (package
     (name "toot")
-    (version "0.37.0")
+    (version "0.38.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "toot" version))
         (sha256
-         (base32 "0qx8hyb74r85dxf97k23w0f5rzkrs16mq7h3y37nwp6hl6gia0ci"))))
+         (base32 "1cn646jzys9vjaw20sxmgzc7zq5a5ma8vabvrw9zpa0yl9wm97my"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -66,7 +66,10 @@
     (native-inputs
      (list python-psycopg2 python-pytest))
     (inputs
-     (list python-beautifulsoup4 python-requests python-urwid
+     (list python-beautifulsoup4
+           python-tomlkit
+           python-requests
+           python-urwid
            python-wcwidth))
     (home-page "https://github.com/ihabunek/toot/")
     (synopsis "Mastodon CLI client")