summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-15 23:30:59 +0200
committerMarius Bakke <marius@gnu.org>2022-08-16 00:43:45 +0200
commit715a5efc4993450a36950f739144c210b56659bd (patch)
tree9f1a3ae460e86468b94e5c59d68fd1564fd06dce
parent90ec03cae3866fc531da5b390b3ad47ccdc4514f (diff)
downloadguix-715a5efc4993450a36950f739144c210b56659bd.tar.gz
gnu: python-pyclipper: Update to 1.3.0.post3.
* gnu/packages/python-xyz.scm (python-pyclipper): Update to 1.3.0.post3.
[source](uri): Use tarball instead of zipball.
[source](snippet): Adjust for renamed file.
[arguments]: Likewise.
[propagated-inputs]: Remove.
[native-inputs]: Remove PYTHON-UNITTEST2 and UNZIP.  Add PYTHON-SETUPTOOLS-SCM.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d183196e10..71c9614242 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20922,31 +20922,29 @@ Rust Python extensions implemented with @code{PyO3} or @code{rust-cpython}.")
 (define-public python-pyclipper
   (package
     (name "python-pyclipper")
-    (version "1.1.0.post3")
+    (version "1.3.0.post3")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "pyclipper" version ".zip"))
+       (uri (pypi-uri "pyclipper" version))
        (sha256
-        (base32 "164yksvqwqvwzh8f8lq92asg87hd8rvcy2xb5vm4y4ccvd5xgb7i"))
+        (base32 "0vqzbmq2di1jaj6230m5i1ld0mg6wdb1c6r6i5zli54varavr7v3"))
       (modules '((guix build utils)))
       (snippet
        '(begin
           ;; This file is generated by Cython.
-          (delete-file "pyclipper/pyclipper.cpp") #t))))
+          (delete-file "src/pyclipper/_pyclipper.cpp") #t))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (add-before 'build 'cythonize-sources
            (lambda _
-             (with-directory-excursion "pyclipper"
-               (invoke "cython" "--cplus" "pyclipper.pyx")))))))
-    (propagated-inputs
-     (list python-setuptools-scm-git-archive))
+             (with-directory-excursion "src/pyclipper"
+               (invoke "cython" "--cplus" "_pyclipper.pyx")))))))
     (native-inputs
-     (list python-cython python-pytest python-pytest-runner
-           python-unittest2 unzip))
+     (list python-cython python-setuptools-scm
+           python-pytest python-pytest-runner))
     (home-page "https://github.com/greginvm/pyclipper")
     (synopsis "Wrapper for Angus Johnson's Clipper library")
     (description