summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-04 17:29:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-07 18:44:03 +0100
commit71601a5d9218b8b3440d58865baf7705b930c585 (patch)
tree461b3352fa41617c3db528b10b715360c967534d
parent03a3ec5e183c397d58eb7761a0e960cbbf85a6bf (diff)
downloadguix-71601a5d9218b8b3440d58865baf7705b930c585.tar.gz
gnu: Add r-softimpute.
* gnu/packages/cran.scm (r-softimpute): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dba3f87efd..01df04b075 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8510,3 +8510,30 @@ with p-value calculation based on Marsaglia's 2004 paper \"Evaluating the
 Anderson-Darling Distribution\".")
     ;; Any version of the GPL.
     (license license:gpl3+)))
+
+(define-public r-softimpute
+  (package
+    (name "r-softimpute")
+    (version "1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "softImpute" version))
+       (sha256
+        (base32
+         "07cxbzkl08q58m1455i139952rmryjlic4s2f2hscl5zxxmfdxcq"))))
+    (properties `((upstream-name . "softImpute")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-matrix" ,r-matrix)))
+    (native-inputs
+     `(("gfortran" ,gfortran)))
+    (home-page "https://cran.r-project.org/web/packages/softImpute")
+    (synopsis "Matrix completion via iterative soft-thresholded SVD")
+    (description
+     "This package provides iterative methods for matrix completion that use
+nuclear-norm regularization.  The package includes procedures for centering
+and scaling rows, columns or both, and for computing low-rank @dfn{single
+value decompositions} (SVDs) on large sparse centered matrices (i.e. principal
+components).")
+    (license license:gpl2)))