summary refs log tree commit diff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-06-12 16:35:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-06-13 11:42:37 +0200
commit7224a1ca6e181d98243bc77828dea23e582aa57e (patch)
tree3ad9f431eafe7f4e4c4aeff7a45d98b23dc2500f
parentb188c41d930dbe8142c1f377d3c8f2580ff1277c (diff)
downloadguix-7224a1ca6e181d98243bc77828dea23e582aa57e.tar.gz
gnu: Add python-mizani.
* gnu/packages/python-xyz.scm (python-mizani): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 968a8e1be9..f2d04a1307 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4109,6 +4109,33 @@ accuracy scores for various music/audio information retrieval/signal
 processing tasks.")
     (license license:expat)))
 
+(define-public python-mizani
+  (package
+    (name "python-mizani")
+    (version "0.9.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/has2k1/mizani")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "13aisfc98nvypb4mglpdphp2r627cjzpdriw4dhlx55f3b2m0dza"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-matplotlib python-numpy python-pandas python-scipy))
+    (native-inputs
+     (list python-setuptools python-pytest python-pytest-cov tzdata))
+    (home-page "https://github.com/has2k1/mizani")
+    (synopsis "Create data visualizations in Python")
+    (description
+     "Mizani is a Python package for creating data visualizations.  It
+provides functions and tools to help with the creation of visually appealing
+and informative visualizations, including scales, transformations and color
+palettes.")
+    (license license:bsd-3)))
+
 (define-public python-pafy
   (package
     (name "python-pafy")