summary refs log tree commit diff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-11 00:09:58 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 13:43:26 +0100
commit72453bfb0ca5ec1eabf0ace88673a5581bf48219 (patch)
tree73a741edf678c53ba905712bcb1fc93aa4ff21dd
parentd43d3bbf3bef881e238368d10c81919028d6cedb (diff)
downloadguix-72453bfb0ca5ec1eabf0ace88673a5581bf48219.tar.gz
gnu: Add go-github-com-libp2p-go-nat.
* gnu/packages/golang-web.scm (go-github-com-libp2p-go-nat): New variable.

Change-Id: I001a5f9370273e99729a315f0357d48822b0d7aa
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index cbd4be9af0..f436d0ce7c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2124,6 +2124,34 @@ router.")
 @acronym{Simple Service Discovery Protocol, SSDP}} library for Golang.")
     (license license:expat)))
 
+(define-public go-github-com-libp2p-go-nat
+  (package
+    (name "go-github-com-libp2p-go-nat")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/libp2p/go-nat")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1yyb3knxvfr7fi759nh7mhh88ap1jpkb7nky7niqrh75737phgh0"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/libp2p/go-nat"))
+    (propagated-inputs
+     (list go-github-com-huin-goupnp
+           go-github-com-jackpal-go-nat-pmp
+           go-github-com-koron-go-ssdp
+           go-github-com-libp2p-go-netroute))
+    (home-page "https://github.com/libp2p/go-nat")
+    (synopsis "NAT port mapping library for Golang")
+    (description
+     "Package @code{go-nat} implements NAT handling facilities.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-libp2p-go-netroute
   (package
     (name "go-github-com-libp2p-go-netroute")