summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-01 16:17:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:35:41 +0300
commit724bd3522486f578d836bfff4b96809825eaf951 (patch)
tree00233edef87ce7115d13ac666d18f23f13c5845e
parent278f8a7de8b2a27f5250bb511fef0504ab33b6a1 (diff)
downloadguix-724bd3522486f578d836bfff4b96809825eaf951.tar.gz
gnu: Add rust-cssparser-0.29.
* gnu/packages/crates-io.scm (rust-cssparser-0.29): New variable.
(rust-cssparser-0.28): Inherit from rust-cssparser-0.29.
-rw-r--r--gnu/packages/crates-io.scm44
1 files changed, 37 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a1a162f131..bdcc50ec63 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17016,37 +17016,67 @@ algorithms.")
 hash functions.")
     (license license:expat)))
 
-(define-public rust-cssparser-0.28
+(define-public rust-cssparser-0.29
   (package
     (name "rust-cssparser")
-    (version "0.28.1")
+    (version "0.29.6")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "cssparser" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1h924c5g2rwlmgk8hllciyky3ih3z9vf04xz3xsp3cv1jyd5kf0x"))))
+        (base32 "1yp0zl5cmw9x95np9a51153fdb1ng8fgzwyssg7hr5dmki0h6ggr"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:skip-build? #t
+     `(#:tests? #f  ; Not all files included in the tarball.
        #:cargo-inputs
        (("rust-cssparser-macros" ,rust-cssparser-macros-0.6)
         ("rust-dtoa-short" ,rust-dtoa-short-0.3)
-        ("rust-itoa" ,rust-itoa-0.4)
+        ("rust-itoa" ,rust-itoa-1)
         ("rust-matches" ,rust-matches-0.1)
-        ("rust-phf" ,rust-phf-0.8)
+        ("rust-phf" ,rust-phf-0.10)
         ("rust-proc-macro2" ,rust-proc-macro2-1)
         ("rust-quote" ,rust-quote-1)
         ("rust-serde" ,rust-serde-1)
         ("rust-smallvec" ,rust-smallvec-1)
-        ("rust-syn" ,rust-syn-1))))
+        ("rust-syn" ,rust-syn-1))
+       #:cargo-development-inputs
+       (("rust-difference" ,rust-difference-2)
+        ("rust-encoding-rs" ,rust-encoding-rs-0.8)
+        ("rust-serde-json" ,rust-serde-json-1))))
     (home-page "https://github.com/servo/rust-cssparser")
     (synopsis "Rust implementation of CSS Syntax Level 3")
     (description
      "This package contains a Rust implementation of CSS Syntax Level 3.")
     (license license:mpl2.0)))
 
+(define-public rust-cssparser-0.28
+  (package
+    (inherit rust-cssparser-0.29)
+    (name "rust-cssparser")
+    (version "0.28.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "cssparser" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1h924c5g2rwlmgk8hllciyky3ih3z9vf04xz3xsp3cv1jyd5kf0x"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-cssparser-macros" ,rust-cssparser-macros-0.6)
+        ("rust-dtoa-short" ,rust-dtoa-short-0.3)
+        ("rust-itoa" ,rust-itoa-0.4)
+        ("rust-matches" ,rust-matches-0.1)
+        ("rust-phf" ,rust-phf-0.8)
+        ("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-smallvec" ,rust-smallvec-1)
+        ("rust-syn" ,rust-syn-1))))))
+
 (define-public rust-cssparser-0.27
   (package
     (inherit rust-cssparser-0.28)