summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-04 15:37:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-12 08:40:37 +0300
commit726a78b8bc490757736edf1187d479aac335a783 (patch)
tree3c5a8b8d900189abbd55be6e720cf4465e8c4e45
parent0d8886679726561e3ecc1c9db1263976107b8bc2 (diff)
downloadguix-726a78b8bc490757736edf1187d479aac335a783.tar.gz
gnu: Add julia-pyplot.
* gnu/packages/julia-xyz.scm (julia-pyplot): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3876b409e9..ecfcd8ef77 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3281,6 +3281,35 @@ types between Julia and Python), define Python classes from Julia methods, and
 share large data structures between Julia and Python without copying them.")
     (license license:expat)))
 
+(define-public julia-pyplot
+  (package
+    (name "julia-pyplot")
+    (version "2.10.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaPy/PyPlot.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "007zs0imfgs69f30pp2a3rc93kl0qiq7qjx6ig35z4wzkmps4skd"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-colors" ,julia-colors)
+       ("julia-latexstrings" ,julia-latexstrings)
+       ("julia-pycall" ,julia-pycall)
+       ("julia-versionparsing" ,julia-versionparsing)
+       ;; python-matplotlib is expected to be available at runtime.
+       ("python-matplotlib" ,python-matplotlib)))
+    (home-page "https://github.com/JuliaPy/PyPlot.jl")
+    (synopsis "Plotting for Julia based on matplotlib.pyplot")
+    (description "This package provides a Julia interface to the Matplotlib
+plotting library from Python, and specifically to the @code{matplotlib.pyplot}
+module.  PyPlot uses the Julia PyCall package to call Matplotlib directly from
+Julia with little or no overhead (arrays are passed without making a copy).")
+    (license license:expat)))
+
 (define-public julia-quadgk
   (package
     (name "julia-quadgk")