summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:35 +0200
commit729868d8a9ccf9f65bcda12d7973b7f0f3dad775 (patch)
tree5b28c45879e2c18259463f4240331a0c99375671
parentadece1dbd33c5ad0255e2669a4c2fde200dddf6e (diff)
downloadguix-729868d8a9ccf9f65bcda12d7973b7f0f3dad775.tar.gz
gnu: Add texlive-syntrace.
* gnu/packages/tex.scm (texlive-syntrace): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2f2876f61d..e7963e590b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96978,6 +96978,28 @@ by applying transformations to the given font's glyph for a tilde.")
 to represent the diagram structure.")
     (license license:gpl3+)))
 
+(define-public texlive-syntrace
+  (package
+    (name "texlive-syntrace")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/syntrace/"
+                   "source/latex/syntrace/"
+                   "tex/latex/syntrace/")
+             (base32
+              "1qdl3vriidpdl3cpa05r2h2dv3i8bmqf5l47313mghyz1pilkrga")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/syntrace")
+    (synopsis "Labels for tracing in a syntax tree")
+    (description
+     "This package adds support for traces in trees created using either the
+@code{synttree} or the @code{qtree} package.  The package provides two
+commands @code{(\\traceLabel} and @code{\\traceReference)} to set and use
+a trace.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar