summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-12 23:34:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-24 21:54:32 +0200
commit72f278a0ff1776a6ad599b9b0f64f87207481398 (patch)
tree25aae20637289c9aae3cdac52b1f01044a1a8560
parent67be8943c387f95e40ae4b746497524cfc26012d (diff)
downloadguix-72f278a0ff1776a6ad599b9b0f64f87207481398.tar.gz
gnu: Add python-sphinxcontrib-htmlhelp.
* gnu/packages/sphinx.scm (python-sphinxcontrib-htmlhelp): New public variable.
-rw-r--r--gnu/packages/sphinx.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 71cff12a2c..3fd4a399c3 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -148,6 +148,26 @@ Apple help books.")
 @url{Devhelp,https://wiki.gnome.org/Apps/Devhelp} documents.")
     (license license:bsd-2)))
 
+(define-public python-sphinxcontrib-htmlhelp
+  (package
+    (name "python-sphinxcontrib-htmlhelp")
+    (version "1.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "sphinxcontrib-htmlhelp" version))
+              (sha256
+               (base32
+                "08l4x8a2l4xjqdd5rhvmfsqihmlgg4prdayj9b6pigaii6gzjw26"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;XXX: circular dependency on Sphinx
+    (home-page "https://github.com/sphinx-doc/sphinxcontrib-htmlhelp")
+    (synopsis "Sphinx exension for rendering HTML help files")
+    (description
+     "@code{sphinxcontrib-htmlhelp} is a Sphinx extension which renders
+HTML help files.")
+    (license license:bsd-2)))
+
 (define-public python-sphinxcontrib-jsmath
   (package
     (name "python-sphinxcontrib-jsmath")