summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-30 12:43:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-30 17:11:25 +0300
commit730f7c096df36f087a7cf9d289cd0f0bece1a5c2 (patch)
treea6f2374897b98d38a0e91a4eb19dc8bd6d5ea0a4
parent9d9b53ed5f79e1d79ab1907faffee1bba0ac422d (diff)
downloadguix-730f7c096df36f087a7cf9d289cd0f0bece1a5c2.tar.gz
gnu: rav1e: Force building with rust edition 2018.
* gnu/packages/video.scm (rav1e)[arguments]: Add phase to force all
input crates to be built with rust edition 2018.
-rw-r--r--gnu/packages/video.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ca6148b078..6a14a85b74 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5285,6 +5285,12 @@ result in several formats:
              (substitute* "Cargo.toml"
                ;; Allow using more recent versions of
                (("~3.1.2") "~3"))))
+         (add-after 'configure 'force-rust-edition-2018
+           (lambda* (#:key vendor-dir #:allow-other-keys)
+             ;; Force all the dependencies to not be higher than edition 2018.
+             (with-fluids ((%default-port-encoding #f))
+               (substitute* (find-files vendor-dir "Cargo.toml")
+                 (("edition = \\\"2021\\\"") "edition = \"2018\"")))))
          (replace 'build
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))