summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2020-12-16 23:03:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-17 11:26:53 +0100
commit7395458d40e156d683a0ce3604c19b38f4488c13 (patch)
tree7e1d4881073475f24f965eaefef3299ba72b0f88
parenteb2f1a7dd94d816cfe5741f4053fc7e9d87eb8f4 (diff)
downloadguix-7395458d40e156d683a0ce3604c19b38f4488c13.tar.gz
gnu: Add r-kegggraph.
* gnu/packages/bioconductor.scm (r-kegggraph): New variable.
-rw-r--r--gnu/packages/bioconductor.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 76c1423bc9..9189e53d17 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9213,3 +9213,29 @@ CATALYST (Cytometry dATa anALYSis Tools) to provide a pipeline for
 preprocessing of cytometry data, including i) normalization using bead
 standards, ii) single-cell deconvolution, and iii) bead-based compensation.")
     (license license:gpl2+)))
+
+(define-public r-kegggraph
+  (package
+    (name "r-kegggraph")
+    (version "1.50.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "KEGGgraph" version))
+       (sha256
+        (base32 "1h293hn02ysm923bh9gxk87xv663xiqchqcvpaxpla9c3yrgkx2v"))))
+    (properties `((upstream-name . "KEGGgraph")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-graph" ,r-graph)
+       ("r-rcurl" ,r-rcurl)
+       ("r-xml" ,r-xml)))
+    (home-page "https://bioconductor.org/packages/KEGGgraph")
+    (synopsis "Graph approach to Kegg Pathway database in R and Bioconductor")
+    (description
+     "@code{r-kegggraph} is an interface between Kegg Pathway database and graph
+object as well as a collection of tools to analyze, dissect and visualize these
+graphs.  It parses the regularly updated kgml (Kegg XML) files into graph models
+maintaining all essential pathway attributes.  The package offers
+functionalities including parsing, graph operation, visualization and etc.")
+    (license license:gpl2+)))