summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 09:58:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:32 +0200
commit73d99c2c0a78e05bd8d6f82c419c3ccda2368a60 (patch)
tree4bf33e9ff3d761ec615f19e3e9ddde6c37b266e1
parentcef8d620b35d1881989e9972e19f0fd6d3ae21c0 (diff)
downloadguix-73d99c2c0a78e05bd8d6f82c419c3ccda2368a60.tar.gz
gnu: Add texlive-detex.
* gnu/packages/tex.scm (texlive-detex): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cb5f161ddb..e6a2c1c65f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1594,6 +1594,29 @@ defined in @code{\\(re)newcommand} or @code{\\(re)newenvironment} commands,
 within the document, or in the document's private package file.")
     (license license:afl2.1)))
 
+(define-public texlive-detex
+  (package
+    (name "texlive-detex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/detex.1"
+                   "doc/man/man1/detex.man1.pdf")
+             (base32
+              "08d017wn7a67pmp9b5yhnfg1x2q6f48qaa5ma4bplz9a782icwjy")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/detex")
+    (synopsis "Strip TeX from a source file")
+    (description
+     "Detex is a program to remove TeX constructs from a text file.  It
+recognizes the @code{\\input} command.  The program assumes it is dealing with
+LaTeX input if it sees the string @code{\\begin@{document@}} in the text.  In
+this case, it also recognizes the @code{\\include} and @code{\\includeonly}
+commands.  The author now considers this program to be obsolete and Piotr
+Kubowicz's OpenDetex as its successor.")
+    (license license:bsd-3)))
+
 (define-public texlive-dvipsconfig
   (package
     (name "texlive-dvipsconfig")