summary refs log tree commit diff
diff options
context:
space:
mode:
authorRouby Pierre-Antoine <pierre-antoine.rouby@inria.fr>2018-05-28 17:03:09 +0200
committerLeo Famulari <leo@famulari.name>2018-05-29 18:39:08 -0400
commit73fe19ef287fd08971429711511cd82cc657acc5 (patch)
tree3f55e06078b842090330a1d498c09279668520b4
parent7979f7df9a6dc846295d1861229cee11483b373c (diff)
downloadguix-73fe19ef287fd08971429711511cd82cc657acc5.tar.gz
gnu: Add go-github-com-google-cadvisor.
* gnu/packages/golang.scm (go-github-com-google-cadvisor): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 12adbff007..a23751ca93 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1546,3 +1546,29 @@ interfaces in Go.")
 developers to use @code{http} methods explicitly and in a way that's consistent
 with the HTTP protocol definition.")
       (license license:expat))))
+
+(define-public go-github-com-google-cadvisor
+  (let ((commit "2ed7198f77395ee9a172878a0a7ab92ab59a2cfd")
+        (revision "0"))
+    (package
+      (name "go-github-com-google-cadvisor")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/google/cadvisor.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1w8p345z5j0gk3yiq5ah0znd5lfh348p2s624k5r10drz04p3f55"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/google/cadvisor"))
+      (home-page "https://github.com/google/cadvisor")
+      (synopsis "Analyze resource usage of running containers")
+      (description "The package provides @code{cadvisor}, which provides
+information about the resource usage and preformance characteristics of running
+containers.")
+      (license license:asl2.0))))