summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 12:31:55 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:02 +0200
commit75805449cfbcf41c530a4faaa7d8d69933aa6b40 (patch)
tree739eae1d4fad1af986f9102d123925147ec46799
parent2d6e56baa78345ea90bfee9f75e311f13e397e6e (diff)
downloadguix-75805449cfbcf41c530a4faaa7d8d69933aa6b40.tar.gz
gnu: Add python-utils.
* gnu/packages/python.scm (python-utils, python2-utils): New variables.
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2ddc25d232..a2560916d7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14191,3 +14191,28 @@ a fork of pytest-capturelog.")
 
 (define-public python2-pytest-catchlog
   (package-with-python2 python-pytest-catchlog))
+
+(define-public python-utils
+  (package
+    (name "python-utils")
+    (version "2.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "python-utils" version))
+              (sha256
+               (base32
+                "1mcsy6q5am4ya72rgkpb6kax6vv7c93cfkkas89xnpa4sj9zf28p"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("pytest-runner" ,python-pytest-runner)
+       ("pytest" ,python-pytest)
+       ("six" ,python-six)))
+    (home-page "https://github.com/WoLpH/python-utils")
+    (synopsis "Convenient utilities not included with the standard Python install")
+    (description
+      "Python Utils is a collection of small Python functions and classes which
+make common patterns shorter and easier.")
+    (license license:bsd-2)))
+
+(define-public python2-utils
+  (package-with-python2 python-utils))