summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-14 23:38:18 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-14 23:45:35 +0200
commit759318fd77f81e9045591923033ccb96c4ab5a16 (patch)
treecdea2eda689309d0990c26f814b0ca6f158cdc56
parent349753743f55ec5a12817230583e2afee93e7777 (diff)
downloadguix-759318fd77f81e9045591923033ccb96c4ab5a16.tar.gz
gnu: gx-slow-gear-lv2: Fix SSE detection.
* gnu/packages/music.scm (gx-slow-gear-lv2)[arguments]: Add phase
"escape-shell-commands".
-rw-r--r--gnu/packages/music.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 9dae8e0ed5..394d124a30 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2307,6 +2307,17 @@ adjusts the amount of harmonics."))))
                  (base32
                   "0c6099h5qkv7ilsvxxcrzwy1h6lkld1srh3fvbjxyw9q34kbqsyl"))
                 (file-name (string-append name "-" version "-checkout"))))
+      (arguments
+       (substitute-keyword-arguments (package-arguments gx-guvnor-lv2)
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (add-after 'unpack 'escape-shell-commands
+               (lambda _
+                 (substitute* "Makefile"
+                   (("cat ") "$(shell cat ")
+                   (("/dev/null") "/dev/null)")
+                   (("SSE_CFLAGS = \"\"") "SSE_CFLAGS ="))
+                 #t))))))
       (home-page "https://github.com/brummer10/GxSlowGear.lv2")
       (synopsis "Slow gear audio effect")
       (description "This package provides the LV2 plugin \"GxSlowGear\", a