summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:39 +0200
commit75cecfaab06b4be9cedaa4882d55fa3f59100a9c (patch)
tree8267ad9460b80fb7e2a439968a26d43d04b4707e
parentfff7fa44c7a9a606baff784676ed9e9ce1876e23 (diff)
downloadguix-75cecfaab06b4be9cedaa4882d55fa3f59100a9c.tar.gz
gnu: Add texlive-tablvar.
* gnu/packages/tex.scm (texlive-tablvar): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4e229b01cf..1600614f2f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -97187,6 +97187,31 @@ slows down compilation of tables, since each entry is boxed twice.")
     ;; provided that this notice is left intact.
     (license (license:fsf-free "file://tex/latex/tabls/tabls.sty"))))
 
+(define-public texlive-tablvar
+  (package
+    (name "texlive-tablvar")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/tablvar/" "source/latex/tablvar/"
+                   "tex/latex/tablvar/")
+             (base32
+              "09avmk6czz2p36mmsyd83i8riblj92vbdb344mp2rh8rjv3myzj8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tablvar")
+    (synopsis
+     "Typesetting pretty tables of signs and variations according to French usage")
+    (description
+     "This is a complete and easy-to-use package for typesetting pretty tables of
+signs and variations according to French usage.  The syntax is similar to that
+of the @code{array} environment and uses intuitive position commands.  Arrows
+are drawn automatically (using PSTricks by default or TikZ as an option).
+Macros are provided for drawing twin bars, single bars crossing the zeros,
+areas where the function is not defined, or placing special values.  Several
+features of the variation tables can be customized.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar