summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-24 20:35:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-24 20:36:51 +0100
commit761c097ff5333501634f360718090b52680e4b7c (patch)
treee4ccad9d1d561f26e5cfb7795f6cd797f4c4693c
parent459dcb95f4642b24062b90478310d84a36bad35a (diff)
downloadguix-761c097ff5333501634f360718090b52680e4b7c.tar.gz
gnu: Add r-brobdingnag.
* gnu/packages/cran.scm (r-brobdingnag): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d9e6c1563b..d8a1233bea 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11931,3 +11931,26 @@ partitions, and restricted partitions of an integer; the three corresponding
 partition functions are also given.")
     ;; Any version of the GPL
     (license license:gpl2+)))
+
+(define-public r-brobdingnag
+  (package
+    (name "r-brobdingnag")
+    (version "1.2-6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "Brobdingnag" version))
+       (sha256
+        (base32
+         "1m3ajvcksqfck5l5hj5xiflj4ry6d896ybv4f0xxks8chgnwmv0r"))))
+    (properties `((upstream-name . "Brobdingnag")))
+    (build-system r-build-system)
+    (home-page "https://github.com/RobinHankin/Brobdingnag.git")
+    (synopsis "Very large numbers in R")
+    (description
+     "This package handles very large numbers in R.  Real numbers are held
+using their natural logarithms, plus a logical flag indicating sign.  The
+package includes a vignette that gives a step-by-step introduction to using S4
+methods.")
+    ;; Any version of the GPL
+    (license license:gpl2+)))