summary refs log tree commit diff
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2023-03-13 23:16:26 +0100
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2023-03-16 09:52:19 +0100
commit7636c49b45adb9870cf416c64bde032ec858a820 (patch)
tree048d85724436742c8236893037b9bc857d2ef08d
parentb29954509f42f05f8764554d259f5a8cdd4ccc6d (diff)
downloadguix-7636c49b45adb9870cf416c64bde032ec858a820.tar.gz
gnu: openjdk10: Build from hg.
* gnu/packages/java.scm (openjdk10)[source]: Use HG-DOWNLOAD.

This fixes <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=62071>
for OpenJDK 10.
-rw-r--r--gnu/packages/java.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index a5e60b7c71..7cf4a4fb4b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1035,19 +1035,17 @@ new Date();"))
     (name "openjdk")
     (version "10.46")
     (source (origin
-              (method url-fetch)
-              (uri "http://hg.openjdk.java.net/jdk/jdk/archive/6fa770f9f8ab.tar.bz2")
-              (file-name (string-append name "-" version ".tar.bz2"))
+              (method hg-fetch)
+              (uri (hg-reference (url "https://hg.openjdk.org/jdk/jdk")
+                                 (changeset "jdk-10+46")))
+              (file-name (hg-file-name name version))
+              (modules '((guix build utils)))
+              (snippet `(begin
+                          (for-each delete-file
+                                    (find-files "." ".*.(bin|exe|jar)$"))))
               (sha256
                (base32
-                "0zywq2203b4hx4jms9vbwvjcj1d3k2v3qpx4s33729fkpmid97r4"))
-              (patches (search-patches
-                        "openjdk-10-idlj-reproducibility.patch"))
-              (modules '((guix build utils)))
-              (snippet
-               `(begin
-                  (for-each delete-file (find-files "." ".*.(bin|exe|jar)$"))
-                  #t))))
+                "0i47ar8lxzjrkkiwbzybfxs473390h4jq9ahm3xqdvy5zpchxy3y"))))
     (arguments
      (substitute-keyword-arguments (package-arguments openjdk9)
        ((#:phases phases)