summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 15:59:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:48 +0200
commit76819a965589b62f83acf083305ae412a9fd91e5 (patch)
treef76ec0b5abd8e816da7ddacd759d8967b377d869
parentab6566e6a1c3c344487af7d55b35a23df7ce9c03 (diff)
downloadguix-76819a965589b62f83acf083305ae412a9fd91e5.tar.gz
gnu: texlive-fonts-ec -> texlive-ec.
* gnu/packages/tex.scm (texlive-ec): New variable.
(texlive-fonts-ec): Deprecate variable.
(lyx):
(biber):
* gnu/packages/python-xyz.scm (python-pypandoc):
* gnu/packages/statistics.scm (r-with-tests):
* doc/build.scm (pdf-manual):
* gnu/packages/bioinformatics.scm (discrover):
(phyml):
(velvet):
* gnu/packages/chemistry.scm (yaehmop):
* gnu/packages/chez.scm (stex-bootstrap):
* gnu/packages/ocaml.scm (unison):
(ocaml-bibtex2html):
* gnu/packages/plotutils.scm (asymptote): Use new name.
-rw-r--r--doc/build.scm2
-rw-r--r--gnu/packages/bioinformatics.scm6
-rw-r--r--gnu/packages/chemistry.scm2
-rw-r--r--gnu/packages/chez.scm8
-rw-r--r--gnu/packages/ocaml.scm4
-rw-r--r--gnu/packages/plotutils.scm2
-rw-r--r--gnu/packages/python-xyz.scm4
-rw-r--r--gnu/packages/statistics.scm8
-rw-r--r--gnu/packages/tex.scm128
9 files changed, 80 insertions, 84 deletions
diff --git a/doc/build.scm b/doc/build.scm
index 0a5bddbcb6..995f4878e1 100644
--- a/doc/build.scm
+++ b/doc/build.scm
@@ -915,7 +915,7 @@ makeinfo OPTIONS."
                      texlive-base
                      texlive-bin        ;for GUIX_TEXMF
                      texlive-epsf
-                     texlive-fonts-ec
+                     texlive-ec
                      texlive-tex-texinfo)))))
 
   (define build
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 22d2722538..6bb188c2c2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4768,7 +4768,7 @@ data and settings.")
             (list texlive-cm
                   texlive-amsfonts
                   texlive-doi
-                  texlive-fonts-ec
+                  texlive-ec
                   texlive-latex-examplep
                   texlive-hyperref
                   texlive-ms
@@ -12106,8 +12106,8 @@ programs for inferring phylogenies (evolutionary trees).")
            (texlive-updmap.cfg (list texlive-amsfonts
                                      texlive-caption
                                      texlive-cite
+                                     texlive-ec
                                      texlive-fancyvrb
-                                     texlive-fonts-ec
                                      texlive-graphics
                                      texlive-grfext
                                      texlive-hyperref
@@ -17090,7 +17090,7 @@ to an artifact/contaminant file.")
      (list openmpi zlib))
     (native-inputs
      `(("texlive" ,(texlive-updmap.cfg (list texlive-graphics
-                                             texlive-fonts-ec
+                                             texlive-ec
                                              texlive-hyperref)))))
     (home-page "https://www.ebi.ac.uk/~zerbino/velvet/")
     (synopsis "Nucleic acid sequence assembler for very short reads")
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index b97703e810..44107e825a 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -900,7 +900,7 @@ emphasis on quality rather than speed.")
     (native-inputs
      (list gfortran
            (texlive-updmap.cfg
-            (list texlive-fonts-ec
+            (list texlive-ec
                   texlive-geometry
                   texlive-graphics))))
     (home-page "https://github.com/greglandrum/yaehmop")
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 2c8d53def8..b988b00fd7 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -760,11 +760,11 @@ Chez Scheme.")))
        (propagated-inputs
         (list xorg-rgb
               (texlive-updmap.cfg
-               (list texlive-l3backend
-                     texlive-hyperref
-                     texlive-bibtex
+               (list texlive-bibtex
+                     texlive-ec
                      texlive-epsf
-                     texlive-fonts-ec
+                     texlive-hyperref
+                     texlive-l3backend
                      texlive-oberdiek))
               ghostscript
               netpbm))
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d3990bdd4d..9e399064c8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1378,7 +1378,7 @@ libpanel, librsvg and quartz.")
        ;; For documentation
        ("ghostscript" ,ghostscript)
        ("texlive" ,(texlive-updmap.cfg
-                    (list texlive-fonts-ec texlive-l3backend)))
+                    (list texlive-ec texlive-l3backend)))
        ("hevea" ,hevea)
        ("lynx" ,lynx)
        ("which" ,which)))
@@ -10255,7 +10255,7 @@ SHA384, SHA512, Blake2b, Blake2s and RIPEMD160.")
     (native-inputs
      `(("which" ,which)
        ("texlive" ,(texlive-updmap.cfg
-                    (list texlive-fonts-ec texlive-preprint
+                    (list texlive-ec texlive-preprint
                           texlive-hyperref texlive-bibtex)))))
     (propagated-inputs
      (list hevea))
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 20b08a74c2..6e4256ea99 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -308,9 +308,9 @@ colors, styles, options and details.")
            texinfo                      ;for generating documentation
            (texlive-updmap.cfg
             (list texlive-amsfonts
+                  texlive-ec
                   texlive-epsf
                   texlive-etoolbox
-                  texlive-fonts-ec
                   texlive-geometry
                   texlive-graphics
                   texlive-grfext
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0165925c70..7edaf1dbc8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29191,11 +29191,11 @@ By default it uses the open Python vulnerability database Safety DB.")
      `(("wheel" ,python-wheel)))
     (native-inputs
      `(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
-                                        texlive-fonts-ec
+                                        texlive-ec
                                         texlive-iftex
                                         texlive-hyperref
-                                        texlive-oberdiek
                                         texlive-lm
+                                        texlive-oberdiek
                                         texlive-xcolor)))))
     (arguments
      `(#:phases
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index a1f96936e4..74a27cec89 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -389,14 +389,14 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
            pkg-config
            texinfo                      ; for building HTML manuals
            (texlive-updmap.cfg (list texlive-ae
-                                     texlive-inconsolata
-                                     texlive-fonts-ec
-                                     texlive-grfext
                                      texlive-amsfonts
-                                     texlive-latex-base
+                                     texlive-ec
                                      texlive-fancyvrb
                                      texlive-graphics
+                                     texlive-grfext
                                      texlive-hyperref
+                                     texlive-inconsolata
+                                     texlive-latex-base
                                      texlive-oberdiek
                                      texlive-tools
                                      texlive-upquote
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 056a4f8a32..8561525d28 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6882,69 +6882,64 @@ package options.")
 
 (define-deprecated-package texlive-latex-kvoptions texlive-kvoptions)
 
-(define-public texlive-fonts-ec
+(define-public texlive-ec
   (package
-    (name "texlive-fonts-ec")
+    (name "texlive-ec")
     (version (number->string %texlive-revision))
-    (source (origin
-              (method svn-fetch)
-              (uri (svn-reference
-                    (url (string-append "svn://www.tug.org/texlive/tags/"
-                                        %texlive-tag "/Master/texmf-dist/"
-                                        "/fonts/source/jknappen/ec/"))
-                    (revision %texlive-revision)))
-              (file-name (string-append name "-" version "-checkout"))
-              (sha256
-               (base32
-                "12av65fbz9xiashm09c9m1fj1mijxls5xspd7652ry1n5s0nixy4"))))
-    (build-system gnu-build-system)
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/ec/"
+                   "fonts/source/jknappen/ec/"
+                   "fonts/tfm/jknappen/ec/")
+             (base32
+              "1cyi0vv9dnp45s0ilsrbkyznj9ji62s5bhkqgh49461mv2f8qj6p")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
     (arguments
-     `(#:modules ((guix build gnu-build-system)
-                  (guix build utils)
-                  (srfi srfi-1)
-                  (srfi srfi-26))
-       #:tests? #f                      ; no tests
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (replace 'build
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((mf (assoc-ref inputs "texlive-metafont")))
-               ;; Tell mf where to find mf.base
-               (setenv "MFBASES" (string-append mf "/share/texmf-dist/web2c"))
-               ;; Tell mf where to look for source files
-               (setenv "MFINPUTS"
-                       (string-append (getcwd) ":"
-                                      mf "/share/texmf-dist/metafont/base:"
-                                      (assoc-ref inputs "texlive-cm")
-                                      "/share/texmf-dist/fonts/source/public/cm")))
-             (mkdir "build")
-             (for-each (lambda (font)
-                         (format #t "building font ~a\n" font)
-                         (invoke "mf" "-progname=mf"
-                                 "-output-directory=build"
-                                 (string-append "\\"
-                                                "mode:=ljfour; "
-                                                "mag:=1; "
-                                                "batchmode; "
-                                                "input " (basename font ".mf"))))
-                       (find-files "." "[0-9]+\\.mf$"))
-             #t))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (tfm (string-append
-                          out "/share/texmf-dist/fonts/tfm/jknappen/ec"))
-                    (mf  (string-append
-                          out "/share/texmf-dist/fonts/source/jknappen/ec")))
-               (for-each (cut install-file <> tfm)
-                         (find-files "build" "\\.*"))
-               (for-each (cut install-file <> mf)
-                         (find-files "." "\\.mf"))
-               #t))))))
+     (list
+      #:modules
+      '((guix build texlive-build-system)
+        (guix build utils)
+        (srfi srfi-1)
+        (srfi srfi-26))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'install 're-generate-fonts-metrics
+            (lambda _
+              (let ((mf #$(this-package-native-input "texlive-metafont"))
+                    (cm #$(this-package-native-input "texlive-cm"))
+                    (root (getcwd)))
+                (mkdir-p "build")
+                (with-directory-excursion "fonts/source/jknappen/ec"
+                  ;; Tell mf where to find mf.base.
+                  (setenv "MFBASES"
+                          (string-append mf "/share/texmf-dist/web2c"))
+                  ;; Tell mf where to look for source files.
+                  (setenv "MFINPUTS"
+                          (string-append
+                           (getcwd) ":"
+                           mf "/share/texmf-dist/metafont/base:"
+                           cm "/share/texmf-dist/fonts/source/public/cm"))
+                  ;; Build font metrics (tfm).
+                  (for-each (lambda (font)
+                              (format #t "building font ~a\n" font)
+                              (invoke "mf" "-progname=mf"
+                                      (string-append "-output-directory="
+                                                     root "/build")
+                                      (string-append "\\"
+                                                     "mode:=ljfour; "
+                                                     "mag:=1; "
+                                                     "batchmode; "
+                                                     "input "
+                                                     (basename font ".mf"))))
+                            (find-files "." "[0-9]+\\.mf$")))
+                ;; Install font metrics at the appropriate location.
+                (for-each
+                 (cut install-file <> "fonts/tfm/jknappen/ec")
+                 (find-files "build/" "\\.tfm$"))))))))
     (native-inputs
-     (list texlive-bin texlive-metafont texlive-cm))
-    (home-page "https://www.ctan.org/pkg/ec")
+     (list texlive-bin texlive-cm texlive-metafont))
+    (home-page "https://ctan.org/pkg/ec")
     (synopsis "Computer modern fonts in T1 and TS1 encodings")
     (description
      "The EC fonts are European Computer Modern Fonts, supporting the complete
@@ -6954,15 +6949,16 @@ files.  The set also contains a Text Companion Symbol font, called @code{tc},
 featuring many useful characters needed in text typesetting, for example
 oldstyle digits, currency symbols (including the newly created Euro symbol),
 the permille sign, copyright, trade mark and servicemark as well as a copyleft
-sign, and many others.  Recent releases of LaTeX2e support the EC fonts.  The
-EC fonts supersede the preliminary version released as the DC fonts.  The
-fonts are available in (traced) Adobe Type 1 format, as part of the
-@code{cm-super} bundle.  The other Computer Modern-style T1-encoded Type 1
-set, Latin Modern, is not actually a direct development of the EC set, and
-differs from the EC in a number of particulars.")
+sign, and many others.  The fonts are available in (traced) Adobe Type
+1 format, as part of the @code{cm-super} bundle.  The other Computer
+Modern-style T1-encoded Type 1 set, Latin Modern, is not actually a direct
+development of the EC set, and differs from the EC in a number of
+particulars.")
     (license (license:fsf-free "https://www.tug.org/svn/texlive/tags/\
 texlive-2019.3/Master/texmf-dist/doc/fonts/ec/copyrite.txt"))))
 
+(define-deprecated-package texlive-fonts-ec texlive-ec)
+
 ;; FIXME: the fonts should be built from source, but running "tex aefonts.tex"
 ;; fails with obscure TeX-typical error messages.
 (define-public texlive-ae
@@ -8944,7 +8940,7 @@ and Karl Berry.")
            qtsvg-5
            zlib))
     (propagated-inputs
-     (list (texlive-updmap.cfg (list texlive-fonts-ec))))
+     (list (texlive-updmap.cfg (list texlive-ec))))
     (native-inputs
      (list python pkg-config))
     (home-page "https://www.lyx.org/")