summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-03 09:57:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-03 12:36:06 +0200
commit76911699c97e9ee848519f47e74d0afe8c67f32c (patch)
tree35cef076a2627d256f0b7b19a47a0d2a999e5bb4
parentd51082e8a5cb1fba2bcfb2e71439edf5ee1b2788 (diff)
downloadguix-76911699c97e9ee848519f47e74d0afe8c67f32c.tar.gz
gnu: emacs-ivy-rich: Update to 0.1.7.
* gnu/packages/emacs-xyz.scm (emacs-ivy-rich): Update to 0.1.7.
-rw-r--r--gnu/packages/emacs-xyz.scm45
1 files changed, 20 insertions, 25 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bc0bb31b08..2e93349860 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11859,35 +11859,30 @@ use it, call @code{M-x ivy-yasnippet} (but make sure you have enabled
 @code{yas-minor-mode} first).")
       (license license:gpl3+))))
 
-;; The 0.1.6 release is incompatible with newer ivy versions, so we instead
-;; pick a more recent snapshot of the repository, see
-;; https://github.com/Yevgnen/ivy-rich/pull/80.
 (define-public emacs-ivy-rich
-  (let ((commit "600b8183ed0be8668dcc548cc2c8cb94b001363b")
-        (revision "2"))
-    (package
-      (name "emacs-ivy-rich")
-      (version (git-version "0.1.6" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/Yevgnen/ivy-rich")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "1dv6vr7fv32v5m04zdy02sdajpvrnpc4i3pbh2dwfv73ff8d8yxm"))))
-      (build-system emacs-build-system)
-      (propagated-inputs
-       (list emacs-ivy))
-      (home-page "https://github.com/Yevgnen/ivy-rich")
-      (synopsis "More friendly interface for @code{ivy}")
-      (description
-       "This package extends Ivy by showing more information in the minibuffer
+  (package
+    (name "emacs-ivy-rich")
+    (version "0.1.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Yevgnen/ivy-rich")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0fn3v6221750hk6hs5rrrr894d53ibgj3yza9rismmj321xwbrh5"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     (list emacs-ivy))
+    (home-page "https://github.com/Yevgnen/ivy-rich")
+    (synopsis "More friendly interface for @code{ivy}")
+    (description
+     "This package extends Ivy by showing more information in the minibuffer
 for each candidate.  It adds columns showing buffer modes, file sizes,
 docstrings, etc.  If @code{emacs-all-the-icons} is installed, it can show
 icons as well.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-avy
   (package