summary refs log tree commit diff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-03-08 20:06:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-03-15 22:54:14 +0100
commit76f96c891c273018fd7091cf51bfd11028957d6e (patch)
treee01f50e9aa2bb535bfc6e91511c36e506a943b2c
parent71ec67ef3f695a590f7f05f3e0b144434edda93b (diff)
downloadguix-76f96c891c273018fd7091cf51bfd11028957d6e.tar.gz
gnu: Add r-carrier.
* gnu/packages/cran.scm (r-carrier): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c9ee42e524..9aa19dd2f5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -614,6 +614,30 @@ SVG (Scalable Vector Graphics) formats.  In addition, it supports literate
 programming packages such as @code{knitr} and @code{rmarkdown}.")
     (license license:expat)))
 
+(define-public r-carrier
+  (package
+    (name "r-carrier")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "carrier" version))
+       (sha256
+        (base32 "0bqnwnnjqjk9q0lxq6kkz9s75ss10lfyyywyyi24m8wppxpw1vqc"))))
+    (properties `((upstream-name . "carrier")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-pryr r-rlang))
+    (home-page "https://github.com/r-lib/carrier")
+    (synopsis "Isolate functions for remote execution")
+    (description
+     "Sending functions to remote processes can be wasteful of resources
+because they carry their environments with them.  With this package, it is
+easy to create functions that are isolated from their environment.  These
+isolated functions, also called crates, print to the console with their total
+size and can be easily tested locally before being sent to a remote.")
+    (license license:gpl3)))
+
 (define-public r-clipr
   (package
     (name "r-clipr")