summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:16:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:14 +0200
commit77427017f78d40cee70e27074fdf74a781e04df8 (patch)
treed418ba0e7294b8ddcf356d0b087e6d75968f1184
parentb3c20e9c10f43e84a106f63ea8a12115f3701250 (diff)
downloadguix-77427017f78d40cee70e27074fdf74a781e04df8.tar.gz
gnu: Add texlive-aiaa.
* gnu/packages/tex.scm (texlive-aiaa): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index befff050ed..0dca40640d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1845,6 +1845,27 @@ improved usability.  The AGU now publishes satisfactory LaTeX materials of its
 own; it is recommended to switch to the official distribution.")
     (license license:lppl)))
 
+(define-public texlive-aiaa
+  (package
+    (name "texlive-aiaa")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/aiaa/" "doc/latex/aiaa/"
+                   "source/latex/aiaa/" "tex/latex/aiaa/")
+             (base32
+              "0l6sp7q53nr1ppxaynfc0q3kf1hg5v22yxyvzjdg028rf1nvbhww")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/aiaa")
+    (synopsis "Typeset AIAA conference papers")
+    (description
+     "This package provides a bundle of LaTeX and BibTeX files and sample
+documents to aid those producing papers and journal articles according to the
+guidelines of the @acronym{AIAA, American Institute of Aeronautics and
+Astronautics}.")
+    (license license:lppl)))
+
 (define-public texlive-aichej
   (package
     (name "texlive-aichej")