summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-15 12:58:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-15 12:58:22 +0300
commit7744119c3e9b4050afa942445d527b9596b63911 (patch)
tree884b9bbdb8120d2332cc2fb9d14571f2c2972f30
parentd2923babf3ac44cb6faa88317f77c98f3016820d (diff)
downloadguix-7744119c3e9b4050afa942445d527b9596b63911.tar.gz
gnu: libinput-minimal: Fix cross-compiling.
* gnu/packages/freedesktop.scm (libinput)[native-inputs]: When
cross-compiling add pkg-config-for-build.
[inputs]: When cross-compiling add check.
-rw-r--r--gnu/packages/freedesktop.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 0a1c9bffb3..6bff3fa967 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -577,14 +577,20 @@ freedesktop.org project.")
        ;; Meson target anyway.
        #:build-type "release"))
     (native-inputs
-     (list check pkg-config))
+     (append (list check pkg-config)
+             (if (%current-target-system)
+               (list pkg-config-for-build)
+               '())))
     (inputs
-     (list cairo
-           glib
-           gtk+
-           libevdev
-           libwacom
-           mtdev))
+     (append (list cairo
+                   glib
+                   gtk+
+                   libevdev
+                   libwacom
+                   mtdev)
+             (if (%current-target-system)
+               (list check)
+               '())))
     (propagated-inputs
      `(;; libinput.h requires <libudev.h>, so propagate it.
        ("udev" ,eudev)))