summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-17 17:31:18 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-21 14:11:32 -0400
commit778a424444b932ccf0c22c91d09b5567b94e8723 (patch)
tree508ad0356830802391f17e06417ea4d7719df919
parentb03f4ff76e7502d4636ff805727df437c17de21a (diff)
downloadguix-778a424444b932ccf0c22c91d09b5567b94e8723.tar.gz
gnu: mmtf-cpp: Update to 1.1.0.
* gnu/packages/chemistry.scm (mmtf-cpp): Update to 1.1.0.
[propagated-inputs]: Add msgpack.

Reviewed-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/chemistry.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 05aaa827f8..2a558ee5b0 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -248,7 +248,7 @@ molecules.")
 (define-public mmtf-cpp
   (package
     (name "mmtf-cpp")
-    (version "1.0.0")
+    (version "1.1.0")
     (source
      (origin
        (method git-fetch)
@@ -258,11 +258,13 @@ molecules.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "17ylramda69plf5w0v5hxbl4ggkdi5s15z55cv0pljl12yvyva8l"))))
+         "0rs2f1ppgqz663c3m22p8wsq6z839bj59zy29chci46ypfhwv6ph"))))
     (build-system cmake-build-system)
     ;; Tests require the soon-to-be-deprecated version 1 of the catch-framework.
-    (arguments
-     '(#:tests? #f))
+    (arguments '(#:tests? #f))
+    ;; There is no support for modern msgpack versions yet (see:
+    ;; https://github.com/rcsb/mmtf-cpp/issues/44).
+    (propagated-inputs (list msgpack))  ;included by mmtf/structure_data.hpp
     (home-page "https://mmtf.rcsb.org/")
     (synopsis "C++ API for the Macromolecular Transmission Format")
     (description "This package is a library for the