summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2021-11-01 16:52:40 -0400
committerMark H Weaver <mhw@netris.org>2021-11-02 09:30:07 -0400
commit77c0a35af24f3bc7c3eda7292225a3052f0d2ebd (patch)
treefa603f9f259470075efb3904434d557fc51b6eca
parenta4666e0a9de3835d12d3d85c7d23b807997ae603 (diff)
downloadguix-77c0a35af24f3bc7c3eda7292225a3052f0d2ebd.tar.gz
gnu: icecat: Add system fonts directory to the sandbox whitelist.
Mitigates <https://bugs.gnu.org/51478#29>.

* gnu/packages/gnuzilla.scm (icecat)[arguments]: In the
'build-sandbox-whitelist' phase, add
"/run/current-system/profile/share/fonts/" to the whitelist.
-rw-r--r--gnu/packages/gnuzilla.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 3aa39bc806..a1f6b5738a 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1138,6 +1138,7 @@ in C/C++.")
                                              "/share/mime")
                              ,(string-append (assoc-ref inputs "font-dejavu")
                                              "/share/fonts")
+                             "/run/current-system/profile/share/fonts"
                              ,@(append-map runpaths-of-input
                                            '("mesa" "ffmpeg"))))))
                     (whitelist-string (string-join whitelist ","))