summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-20 18:15:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-22 11:29:30 +0200
commit789286ebd91dac2f85ffc4aa65612f011a8bebd3 (patch)
treebf8507a108f560555563b53608480e47433a4814
parente6586f55e0b2505b31f102d8456ce01e03fece0e (diff)
downloadguix-789286ebd91dac2f85ffc4aa65612f011a8bebd3.tar.gz
gnu: python-zarr: Update to 2.17.2.
* gnu/packages/python-xyz.scm (python-zarr): Update to 2.17.2.
[arguments]: Delete two flaky tests.

Change-Id: I1ab1c90f17d17a03c6cd76bbeb9112df741cc9c6
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c0eebde7ae..a0f3bb72be 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27312,19 +27312,23 @@ codecs for use in data storage and communication applications.")
 (define-public python-zarr
   (package
     (name "python-zarr")
-    (version "2.17.1")
+    (version "2.17.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "zarr" version))
        (sha256
         (base32
-         "0qb2wj60i7v1c95k6m0pskx20ss6dxrj3ym0d7z4c98jfah3ljsn"))))
+         "1kjj0pk0s6306ljrig77m39zqdy32ch4nyja5lalab9l9v5sdfic"))))
     (build-system pyproject-build-system)
     (arguments
      (list
       #:test-flags
-      #~(list "-n" "auto")
+      #~(list "-n" "auto"
+              ;; This tests are flaky.  The pass several times on my laptop
+              ;; but occasionally fail.  They fail pretty reliably on the
+              ;; build farm.
+              "-k not test_lazy_loader and not open_array")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'disable-service-tests