summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:51 +0200
commit78e8b9b34d4cc173e2617ad5daa3b1c19d87e400 (patch)
tree79f48ab7cb18e2d4a33021aa04042ee5cfab55b7
parent5b4e04723eff7ebe81585c99d02406c9e0e02b8d (diff)
downloadguix-78e8b9b34d4cc173e2617ad5daa3b1c19d87e400.tar.gz
gnu: Add texlive-texshade.
* gnu/packages/tex.scm (texlive-texshade): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 16e8f23355..d39652f19d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -97855,6 +97855,31 @@ for preparing slides (such as @code{foiltex} or @code{seminar}) or another
 package such as @code{pdfslide}.")
     (license license:gpl3+)))
 
+(define-public texlive-texshade
+  (package
+    (name "texlive-texshade")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/texshade/"
+                   "source/latex/texshade/"
+                   "tex/latex/texshade/")
+             (base32
+              "00vja01rqbvl205lw2wgf256hdr641mq2s7rh180rhjybqlj7m0h")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/texshade")
+    (synopsis "Package for setting nucleotide and peptide alignments")
+    (description
+     "TeXshade is alignment shading software completely written in TeX/LaTeX; it
+can process multiple sequence alignments in the @file{.msf} and the
+@file{.aln} file formats.  In addition to common shading algorithms, it
+provides special shading modes showing functional aspects, e.g., charge or
+hydropathy, and a wide range of commands for handling shading colours, text
+styles, labels, legends; it even allows the user to define completely new
+shading modes.")
+    (license license:gpl2)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar