summary refs log tree commit diff
diff options
context:
space:
mode:
authorSiniša Biđin <sinisa@bidin.eu>2015-09-11 03:11:51 -0500
committerEric Bavier <bavier@member.fsf.org>2015-09-11 03:23:13 -0500
commit78edf44ce77f40a163403467bafb64dc2d410cfb (patch)
tree2f885dd48d6c8daccf63894503c637dd63a5e6e1
parent6e38c4be4fc1de24c03cd556df98374babaf9666 (diff)
downloadguix-78edf44ce77f40a163403467bafb64dc2d410cfb.tar.gz
gnu: Add ghc-xmonad-contrib.
* gnu/packages/wm.scm (ghc-xmonad-contrib): New variable.

Signed-off-by: Eric Bavier <bavier@member.fsf.org>
-rw-r--r--gnu/packages/wm.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f85bca491a..9ca5b96fe8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -194,3 +194,31 @@ config files.  Layouts are applied dynamically, and different layouts may be
 used on each workspace.  Xinerama is fully supported, allowing windows to be
 tiled on several screens.")
     (license bsd-3)))
+
+(define-public ghc-xmonad-contrib
+  (package
+    (name "ghc-xmonad-contrib")
+    (version "0.11.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://hackage.haskell.org/package/xmonad-contrib/"
+                           "xmonad-contrib-" version ".tar.gz"))
+       (sha256
+        (base32
+         "14h9vr33yljymswj50wbimav263y9abdcgi07mvfis0zd08rxqxa"))))
+    (build-system haskell-build-system)
+    (propagated-inputs
+     `(("ghc-mtl" ,ghc-mtl)
+       ("ghc-random" ,ghc-random)
+       ("ghc-utf8-string" ,ghc-utf8-string)
+       ("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
+       ("ghc-x11" ,ghc-x11)
+       ("ghc-x11-xft" ,ghc-x11-xft)
+       ("xmonad" ,xmonad)))
+    (home-page "http://xmonad.org")
+    (synopsis "Third party extensions for xmonad")
+    (description
+     "Third party tiling algorithms, configurations, and scripts to Xmonad, a
+tiling window manager for X.")
+    (license bsd-3)))