summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-08 13:34:11 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-08 14:39:11 +0200
commit797e1401feda5c32c67c2069afdbdc29792dfa78 (patch)
tree0cc8d926b96b03f7fbec38a5b5278e31a0a312c1
parent3c4010b1e966ca112470eba262de2835815ba218 (diff)
downloadguix-797e1401feda5c32c67c2069afdbdc29792dfa78.tar.gz
gnu: python-h5py: Fix path to hdf5 library.
* gnu/packages/python.scm (python-h5py)[arguments]: Add "fix-hdf5-paths"
  phase.
-rw-r--r--gnu/packages/python.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4faa08fe25..e94a2ebba2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -596,13 +596,28 @@ and verifies that it matches the intended target hostname.")
        (base32
         "0q4f9l8grf6pwp64xbv8bmyxx416s7h4522nnxac056ap3savbps"))))
     (build-system python-build-system)
+    (arguments
+     `(#:tests? #f ; no test target
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-hdf5-paths
+          (lambda* (#:key inputs #:allow-other-keys)
+            (let ((prefix (assoc-ref inputs "hdf5")))
+              (substitute* "setup_build.py"
+                (("\\['/opt/local/lib', '/usr/local/lib'\\]")
+                 (string-append "['" prefix "/lib" "']"))
+                (("'/opt/local/include', '/usr/local/include'")
+                 (string-append "'" prefix "/include" "'")))
+              (substitute* "setup_configure.py"
+                (("\\['/usr/local/lib', '/opt/local/lib'\\]")
+                 (string-append "['" prefix "/lib" "']")))
+              #t))))))
     (propagated-inputs
      `(("python-numpy" ,python-numpy)))
     (inputs
      `(("hdf5" ,hdf5)))
     (native-inputs
      `(("python-cython" ,python-cython)))
-    (arguments `(#:tests? #f)) ; no test target
     (home-page "http://www.h5py.org/")
     (synopsis "Read and write HDF5 files from Python")
     (description