summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-02-17 16:55:07 -0500
committerLeo Famulari <leo@famulari.name>2018-03-15 10:57:51 -0400
commit799ad71bfc05f084d595ee11b608745a9c56eb10 (patch)
tree01658d43cac2914a6ecb4abe4d180093a95e0c31
parent41835f947e84b99d2b8aa5e32c68db2016c7437a (diff)
downloadguix-799ad71bfc05f084d595ee11b608745a9c56eb10.tar.gz
gnu: Add r-desolve.
* gnu/packages/maths.scm (r-desolve): New variable.
-rw-r--r--gnu/packages/maths.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5382260f3c..b372ad9874 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3777,3 +3777,32 @@ It solves unconstrained optimization problems using a simplex method on
 subspaces.  The method is well suited for optimizing objective functions that
 are noisy or are discontinuous at the solution.")
     (license license:gpl3+)))
+
+(define-public r-desolve
+  (package
+    (name "r-desolve")
+    (version "1.20")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "deSolve" version))
+        (sha256
+         (base32
+          "18nx3maww979a8p8ly4hv63y65mnjx8vbj2fpipd6rhcbf1lbsan"))))
+    (properties `((upstream-name . "deSolve")))
+    (build-system r-build-system)
+    (native-inputs
+     `(("gfortran" ,gfortran)))
+    (home-page "https://desolve.r-forge.r-project.org/")
+    (synopsis "Solvers for initial value problems of differential equations")
+    (description "This package provides functions that solve initial
+value problems of a system of first-order ordinary differential equations (ODE),
+of partial differential equations (PDE), of differential algebraic equations
+(DAE), and of delay differential equations.  The functions provide an interface
+to the FORTRAN functions lsoda, lsodar, lsode, lsodes of the ODEPACK collection,
+to the FORTRAN functions dvode and daspk and a C-implementation of solvers of
+the Runge-Kutta family with fixed or variable time steps.  The package contains
+routines designed for solving ODEs resulting from 1-D, 2-D and 3-D partial
+differential equations (PDE) that have been converted to ODEs by numerical
+differencing.")
+    (license license:gpl2+)))