summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-05 11:48:59 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-05 11:48:59 +0200
commit79edda38742b37603ccd48dd8660ff7fcfca293e (patch)
tree21fd8c92fe7ef080f669595f3418591f92f39cd0
parent48bd27863ff5d6445dd393294fc6aec1f93a0d6a (diff)
downloadguix-79edda38742b37603ccd48dd8660ff7fcfca293e.tar.gz
gnu: opencpn: Fix building with gcc 10.
* gnu/packages/geo.scm (opencpn)[arguments]: Pass '-fcommon' to CFLAGS.
-rw-r--r--gnu/packages/geo.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index e2d34f12a2..0276bf5c16 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1885,7 +1885,8 @@ exchanged form one Spatial DBMS and the other.")
      `(#:configure-flags '("-DENABLE_PORTAUDIO=ON"
                            "-DENABLE_SNDFILE=ON"
                            "-DBUNDLE_TCDATA=ON"
-                           "-DBUNDLE_GSHHS=CRUDE")
+                           "-DBUNDLE_GSHHS=CRUDE"
+                           "-DCMAKE_C_FLAGS=-fcommon")
        #:tests? #f ; No tests defined
        #:phases
        (modify-phases %standard-phases