summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-03 12:51:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:47 +0200
commit7a18bd9e74b56a04ec7e4e120789e91d78830444 (patch)
tree2f245364b9bc842cd22adb37d792c99ba02b3a88
parentf37146969a2f24530fcdf270b2d19602809cb4ae (diff)
downloadguix-7a18bd9e74b56a04ec7e4e120789e91d78830444.tar.gz
gnu: Rationalize texlive-updmap.cfg and texlive-tiny inputs.
TEXLIVE-UPDMAP.CFG and TEXLIVE-TINY should only be used as native inputs.
Also remove texlive packages already provided by them.

* doc/build.scm (pdf-manual):
* gnu/packages/algebra.scm (pari-gp):
* gnu/packages/bioinformatics.scm (discrover):
(phyml):
(velvet):
* gnu/packages/chemistry.scm (yaehmop):
* gnu/packages/chez.scm (stex-bootstrap):
(chez-web):
(chez-sockets):
* gnu/packages/cran.scm (r-prereg):
* gnu/packages/docbook.scm (dblatex):
* gnu/packages/emacs-xyz.scm (emacs-auctex):
* gnu/packages/engineering.scm (fastcap):
* gnu/packages/fsf.scm (book-faif):
* gnu/packages/graphviz.scm (dot2tex):
* gnu/packages/maths.scm (hypre):
* gnu/packages/ocaml.scm (unison):
(ocaml-bibtex2html):
* gnu/packages/plotutils.scm (asymptote):
* gnu/packages/python-xyz.scm (python-nbconvert):
(python-pypandoc):
* gnu/packages/radio.scm (gnuradio):
(libosmo-dsp):
* gnu/packages/statistics.scm (r-with-tests):
* gnu/packages/tex.scm (texlive-makecmds):
(texlive-innerscript):
(teximpatient):
(texlive-xkeyval): Remove texlive packages already provided by
TEXLIVE-UPDMAP.CFG.  Don't add TEXLIVE-TINY or TEXLIVE-UPDMAP.CFG as inputs.
-rw-r--r--doc/build.scm4
-rw-r--r--gnu/packages/algebra.scm3
-rw-r--r--gnu/packages/bioinformatics.scm20
-rw-r--r--gnu/packages/chemistry.scm5
-rw-r--r--gnu/packages/chez.scm20
-rw-r--r--gnu/packages/cran.scm2
-rw-r--r--gnu/packages/docbook.scm18
-rw-r--r--gnu/packages/emacs-xyz.scm3
-rw-r--r--gnu/packages/engineering.scm2
-rw-r--r--gnu/packages/fsf.scm3
-rw-r--r--gnu/packages/graphviz.scm3
-rw-r--r--gnu/packages/maths.scm82
-rw-r--r--gnu/packages/ocaml.scm10
-rw-r--r--gnu/packages/plotutils.scm8
-rw-r--r--gnu/packages/python-xyz.scm28
-rw-r--r--gnu/packages/radio.scm11
-rw-r--r--gnu/packages/statistics.scm10
-rw-r--r--gnu/packages/tex.scm34
18 files changed, 85 insertions, 181 deletions
diff --git a/doc/build.scm b/doc/build.scm
index 577f900e20..2cd57b4a92 100644
--- a/doc/build.scm
+++ b/doc/build.scm
@@ -913,9 +913,7 @@ makeinfo OPTIONS."
                      tar
                      texinfo
                      (texlive-updmap.cfg
-                      (list texlive-ec
-                            texlive-epsf
-                            texlive-texinfo)))))))
+                      (list texlive-epsf texlive-texinfo)))))))
 
   (define build
     (with-imported-modules '((guix build utils))
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index c755bc7060..896cf1bb9a 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -236,8 +236,7 @@ the real span of the lattice.")
                (base32
                 "03swii601kxnphl6v7wv0rh2xn4rz6xbljzvfw5v9py6w3z5nm63"))))
     (build-system gnu-build-system)
-    (native-inputs (list (texlive-updmap.cfg
-                          (list texlive-amsfonts))))
+    (native-inputs (list texlive-tiny))
     (inputs (list gmp libx11 perl readline))
     (arguments
      '(#:make-flags '("all")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5021eea6c1..aff5a552e7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4765,15 +4765,10 @@ data and settings.")
      (list boost cairo rmath-standalone))
     (native-inputs
      (list (texlive-updmap.cfg
-            (list texlive-cm
-                  texlive-amsfonts
-                  texlive-doi
-                  texlive-ec
+            (list texlive-doi
                   texlive-examplep
-                  texlive-hyperref
                   texlive-ms
                   texlive-natbib
-                  texlive-bibtex        ;style files used by natbib
                   texlive-pgf           ;tikz
                   texlive-verbatimbox))
            imagemagick))
@@ -12104,14 +12099,9 @@ programs for inferring phylogenies (evolutionary trees).")
            autoconf
            openmpi
            (texlive-updmap.cfg
-            (list texlive-amsfonts
-                  texlive-caption
+            (list texlive-caption
                   texlive-cite
-                  texlive-ec
                   texlive-fancyvrb
-                  texlive-graphics
-                  texlive-grfext
-                  texlive-hyperref
                   texlive-infwarerr
                   texlive-kvoptions
                   texlive-pdftexcmds
@@ -17094,11 +17084,7 @@ to an artifact/contaminant file.")
      (list openmpi zlib))
     (native-inputs
      (list (texlive-updmap.cfg
-            (list texlive-ec
-                  texlive-graphics
-                  texlive-grfext
-                  texlive-hyperref
-                  texlive-infwarerr
+            (list texlive-infwarerr
                   texlive-kvoptions
                   texlive-pdftexcmds))))
     (home-page "https://www.ebi.ac.uk/~zerbino/velvet/")
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 95c5905cf3..bee540bc16 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -900,10 +900,7 @@ emphasis on quality rather than speed.")
     (native-inputs
      (list gfortran
            (texlive-updmap.cfg
-            (list texlive-ec
-                  texlive-epstopdf
-                  texlive-geometry
-                  texlive-graphics
+            (list texlive-epstopdf
                   texlive-latexmk))))
     (home-page "https://github.com/greglandrum/yaehmop")
     (synopsis "Perform extended Hückel calculations")
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 86dd47d2ec..99c8dcac3a 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -759,13 +759,7 @@ Chez Scheme.")))
        ;; though it would probably be easy to add.
        (propagated-inputs
         (list xorg-rgb
-              (texlive-updmap.cfg
-               (list texlive-bibtex
-                     texlive-ec
-                     texlive-epsf
-                     texlive-hyperref
-                     texlive-l3backend
-                     texlive-oberdiek))
+              (texlive-updmap.cfg (list texlive-epsf))
               ghostscript
               netpbm))
        ;; Debian uses a versionless path for STEXLIB,
@@ -1018,14 +1012,8 @@ create compilers, making them easier to understand and maintain.")
              ;;     mktexpk: don't know how to create bitmap font for bchr8r
              ;; Replacing the following with `texlive` fixes it.
              ;; What is missing?
-             (texlive-updmap.cfg (list texlive-oberdiek
-                                       texlive-epsf
-                                       texlive-metapost
-                                       texlive-charter
-                                       texlive-pdftex
-                                       texlive-context
-                                       texlive-cm
-                                       texlive-plain))))
+             (texlive-updmap.cfg
+              (list texlive-context texlive-epsf texlive-metapost))))
       (arguments
        (list
         #:make-flags
@@ -1079,7 +1067,7 @@ programming in Scheme.")
       (native-inputs
        (list (chez-scheme-for-system)
              chez-web
-             (texlive-updmap.cfg (list texlive-pdftex))))
+             texlive-tiny))
       (arguments
        (list
         #:tests? #f ; no tests
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c4276ea147..bc2f7acb7f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -36207,7 +36207,7 @@ package online.")
            texlive-tools
            texlive-ulem
            texlive-upquote
-           (texlive-updmap.cfg (list texlive-amsfonts texlive-lm))))
+           (texlive-updmap.cfg (list texlive-lm))))
     (home-page "https://github.com/crsh/prereg")
     (synopsis
      "R Markdown Templates to preregister Scientific Studies")
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index f16c8130e4..ff6d32b168 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -534,38 +534,30 @@ the in DocBook SGML DTDs.")
     (build-system python-build-system)
     ;; TODO: Add xfig/transfig for fig2dev utility
     (inputs
-     `(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
-                                             texlive-anysize
+     `(("texlive" ,(texlive-updmap.cfg (list texlive-anysize
                                              texlive-appendix
-                                             texlive-bookmark
                                              texlive-changebar
-                                             texlive-colortbl
                                              texlive-fancybox
-                                             texlive-fancyhdr
                                              texlive-fancyvrb
                                              texlive-float
                                              texlive-footmisc
-                                             texlive-hyperref
                                              texlive-jknapltx
                                              texlive-listings
                                              texlive-multirow
                                              texlive-overpic
                                              texlive-pdfpages
                                              texlive-refcount
-                                             texlive-subfigure
-                                             texlive-titlesec
-                                             texlive-wasysym
-
                                              texlive-rsfs
                                              texlive-stmaryrd
-
-                                             texlive-iftex)))
+                                             texlive-subfigure
+                                             texlive-titlesec
+                                             texlive-wasysym)))
        ("imagemagick" ,imagemagick)     ;for convert
        ("inkscape" ,inkscape/stable)    ;for svg conversion
        ("docbook" ,docbook-xml)
        ("libxslt" ,libxslt)))           ;for xsltproc
     (arguments
-     `(;; Using setuptools causes an invalid "package_base" path in
+     `( ;; Using setuptools causes an invalid "package_base" path in
        ;; out/bin/.dblatex-real due to a missing leading '/'.  This is caused
        ;; by dblatex's setup.py stripping the root path when creating the
        ;; script.  (dblatex's setup.py still uses distutils and thus has to
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 748add0cae..39c539afe7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3985,8 +3985,7 @@ as a library for other Emacs packages.")
     (native-inputs
      (list perl))
     (inputs
-     (list ghostscript
-           (texlive-updmap.cfg (list texlive-amsfonts))))
+     (list ghostscript))
     (home-page "https://www.gnu.org/software/auctex/")
     (synopsis "Integrated environment for TeX")
     (description
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 4499d9e07c..8ee8e99b34 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -578,7 +578,7 @@ featuring various improvements and bug fixes.")))
      ;; FIXME: with texlive-tiny citation references are rendered as question
      ;; marks.  During the build warnings like these are printed:
      ;; LaTeX Warning: Citation `nabors91' on page 2 undefined on input line 3.
-     `(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts)))
+     `(("texlive" ,texlive-tiny)
        ("ghostscript" ,ghostscript)))
     (arguments
      `(#:make-flags '("CC=gcc" "RM=rm" "SHELL=sh" "all")
diff --git a/gnu/packages/fsf.scm b/gnu/packages/fsf.scm
index b07ad14164..e952978bbf 100644
--- a/gnu/packages/fsf.scm
+++ b/gnu/packages/fsf.scm
@@ -39,12 +39,9 @@
     (native-inputs
      (list (texlive-updmap.cfg
             (list texlive-caption
-                  texlive-ec
                   texlive-endnotes
                   texlive-fncychap
-                  texlive-geometry
                   texlive-helvetic
-                  texlive-hyperref
                   texlive-times
                   texlive-ucs))))
     (arguments
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 08dd73b24f..b91c365e3c 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -382,8 +382,7 @@ graphs in Graphviz's DOT language, written in pure Python.")
     (native-inputs
      (list python-pytest
            (texlive-updmap.cfg
-            (list texlive-geometry
-                  texlive-pgf
+            (list texlive-pgf
                   texlive-preview
                   texlive-pstricks
                   texlive-xcolor
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 5083b5bb6b..27ded198d0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5777,50 +5777,44 @@ set.")
            python
            python-breathe
            python-sphinx
-           (texlive-updmap.cfg (list texlive-adjustbox
-                                     texlive-alphalph
-                                     texlive-amsfonts
-                                     texlive-bibtex
-                                     texlive-capt-of
-                                     texlive-caption
-                                     texlive-cm
-                                     texlive-cmap
-                                     texlive-colortbl
-                                     texlive-courier
-                                     texlive-enumitem
-                                     texlive-etoc
-                                     texlive-etoolbox
-                                     texlive-fancyhdr
-                                     texlive-fancyvrb
-                                     texlive-float
-                                     texlive-fncychap
-                                     texlive-framed
-                                     texlive-geometry
-                                     texlive-hanging
-                                     texlive-helvetic
-                                     texlive-hyperref
-                                     texlive-jknapltx
-                                     texlive-latexmk
-                                     texlive-listofitems
-                                     texlive-multirow
-                                     texlive-natbib
-                                     texlive-needspace
-                                     texlive-newunicodechar
-                                     texlive-parskip
-                                     texlive-sectsty
-                                     texlive-stackengine
-                                     texlive-tabulary
-                                     texlive-tex-gyre
-                                     texlive-titlesec
-                                     texlive-tocloft
-                                     texlive-ulem
-                                     texlive-upquote
-                                     texlive-varwidth
-                                     texlive-wasy
-                                     texlive-wasysym
-                                     texlive-wrapfig
-                                     texlive-xcolor
-                                     texlive-xypic))))
+           (texlive-updmap.cfg
+            (list texlive-adjustbox
+                  texlive-alphalph
+                  texlive-capt-of
+                  texlive-caption
+                  texlive-cmap
+                  texlive-courier
+                  texlive-enumitem
+                  texlive-etoc
+                  texlive-etoolbox
+                  texlive-fancyvrb
+                  texlive-float
+                  texlive-fncychap
+                  texlive-framed
+                  texlive-hanging
+                  texlive-helvetic
+                  texlive-jknapltx
+                  texlive-latexmk
+                  texlive-listofitems
+                  texlive-multirow
+                  texlive-natbib
+                  texlive-needspace
+                  texlive-newunicodechar
+                  texlive-parskip
+                  texlive-sectsty
+                  texlive-stackengine
+                  texlive-tabulary
+                  texlive-tex-gyre
+                  texlive-titlesec
+                  texlive-tocloft
+                  texlive-ulem
+                  texlive-upquote
+                  texlive-varwidth
+                  texlive-wasy
+                  texlive-wasysym
+                  texlive-wrapfig
+                  texlive-xcolor
+                  texlive-xypic))))
     (inputs
      (list openblas lapack))
     (arguments
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e919c40973..bc09b111ab 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1377,8 +1377,7 @@ libpanel, librsvg and quartz.")
      `(("ocaml" ,ocaml-4.09)
        ;; For documentation
        ("ghostscript" ,ghostscript)
-       ("texlive" ,(texlive-updmap.cfg
-                    (list texlive-ec texlive-l3backend)))
+       ("texlive" ,texlive-tiny)
        ("hevea" ,hevea)
        ("lynx" ,lynx)
        ("which" ,which)))
@@ -10258,12 +10257,9 @@ SHA384, SHA512, Blake2b, Blake2s and RIPEMD160.")
               (setenv "HOME" (getcwd)))))))
     (native-inputs
      (list (texlive-updmap.cfg
-            (list texlive-bibtex
-                  texlive-hyperref
-                  texlive-infwarerr
+            (list texlive-infwarerr
                   texlive-kvoptions
-                  texlive-pdftexcmds
-                  texlive-preprint))
+                  texlive-pdftexcmds))
            which))
     (propagated-inputs
      (list hevea))
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 00ddd34355..06ffa95532 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -307,18 +307,12 @@ colors, styles, options and details.")
            rapidjson
            texinfo                      ;for generating documentation
            (texlive-updmap.cfg
-            (list texlive-amsfonts
-                  texlive-ec
-                  texlive-epsf
+            (list texlive-epsf
                   texlive-etoolbox
-                  texlive-geometry
-                  texlive-grfext
-                  texlive-hyperref
                   texlive-infwarerr
                   texlive-kvdefinekeys
                   texlive-kvoptions
                   texlive-media9
-                  texlive-oberdiek      ;for ifluatex
                   texlive-ocgx2
                   texlive-parskip
                   texlive-pdftexcmds
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac560bfcfd..2d8a942309 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15200,17 +15200,15 @@ time.")
            texlive-ulem
            texlive-unicode-math
            texlive-xcolor
-           (texlive-updmap.cfg (list texlive-amsfonts
-                                     texlive-amsmath
-                                     texlive-eurosym
-                                     texlive-jknapltx
-                                     texlive-lm
-                                     texlive-lm-math
-                                     texlive-mathpazo
-                                     texlive-oberdiek
-                                     texlive-rsfs
-                                     texlive-ucs
-                                     texlive-zapfding))))
+           (texlive-updmap.cfg
+            (list texlive-eurosym
+                  texlive-jknapltx
+                  texlive-lm
+                  texlive-lm-math
+                  texlive-mathpazo
+                  texlive-rsfs
+                  texlive-ucs
+                  texlive-zapfding))))
     (home-page "https://jupyter.org")
     (synopsis "Converting Jupyter Notebooks")
     (description "The @code{nbconvert} tool, @code{jupyter nbconvert}, converts
@@ -29190,13 +29188,7 @@ By default it uses the open Python vulnerability database Safety DB.")
     (propagated-inputs
      `(("wheel" ,python-wheel)))
     (native-inputs
-     `(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
-                                        texlive-ec
-                                        texlive-iftex
-                                        texlive-hyperref
-                                        texlive-lm
-                                        texlive-oberdiek
-                                        texlive-xcolor)))))
+     `(("texlive" ,(texlive-updmap.cfg (list texlive-lm texlive-xcolor)))))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 0ef9896de9..43c9f22c66 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -709,10 +709,8 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
            python-pyzmq
            python-scipy
            python-sphinx
-           (texlive-updmap.cfg (list texlive-amsfonts
-                                     texlive-amsmath
-                                     ;; TODO: Add newunicodechar.
-                                     texlive-graphics))
+           texlive-tiny
+           (texlive-updmap.cfg (list texlive-newunicodechar))
            xorg-server-for-tests))
     (inputs
      (list alsa-lib
@@ -919,10 +917,7 @@ to access different radio hardware.")
        ("doxygen" ,doxygen)
        ("libtool" ,libtool)
        ("pkg-config" ,pkg-config)
-       ("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
-                                        texlive-amsmath
-                                        ;; TODO: Add newunicodechar.
-                                        texlive-graphics)))))
+       ("texlive" ,(texlive-updmap.cfg (list texlive-newunicodechar)))))
     (inputs
      (list fftwf))
     (arguments
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 1cea3afda5..51c41bb0b8 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -389,17 +389,9 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
            pkg-config
            texinfo                      ; for building HTML manuals
            (texlive-updmap.cfg
-            (list texlive-ae
-                  texlive-amsfonts
-                  texlive-ec
-                  texlive-fancyvrb
-                  texlive-grfext
-                  texlive-hyperref
+            (list texlive-fancyvrb
                   texlive-inconsolata
-                  texlive-oberdiek
-                  texlive-tools
                   texlive-upquote
-                  texlive-url
                   texlive-xkeyval))
            tzdata-for-tests
            xz))
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 47bbc243a6..39695080a4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8243,10 +8243,7 @@ diagrams.")
               "05y5n265in7mrbpgjxqg339l8r8dmp6lvl4k528pr3rkb8z94qaf")))
     (outputs '("out" "doc"))
     (build-system texlive-build-system)
-    (native-inputs
-     (list (texlive-updmap.cfg
-            (list texlive-amsfonts
-                  texlive-cm))))
+    (native-inputs (list texlive-tiny))
     (home-page "https://www.ctan.org/pkg/makecmds")
     (synopsis "TeX macro to define or redefine a command")
     (description "The package provides a @code{\\makecommand} command, which
@@ -9487,13 +9484,9 @@ TeX, and LaTeX font definition and other relevant files.")
                 (("\\DocInput\\{innerscript.dtx\\}") "")))))))
     (native-inputs
      (list (texlive-updmap.cfg
-            (list texlive-amsfonts
-                  texlive-booktabs
-                  texlive-epstopdf-pkg
+            (list texlive-booktabs
                   texlive-etoolbox
-                  texlive-geometry
                   texlive-hypdoc
-                  texlive-hyperref
                   texlive-infwarerr
                   texlive-kvoptions
                   texlive-microtype
@@ -11531,13 +11524,13 @@ and PostScript specials.  A working TeX installation is needed.")
                           (("timestamp.*%")
                            (string-append "timestamp{"
                                           ,version "}"))))))))
-      (native-inputs (list autoconf automake
-                           (texlive-updmap.cfg (list texlive-amsfonts
-                                                     texlive-palatino
-                                                     texlive-zapfding
-                                                     texlive-knuth-lib
-                                                     texlive-mflogo-font
-                                                     texlive-pdftex))))
+      (native-inputs
+       (list autoconf
+             automake
+             (texlive-updmap.cfg
+              (list texlive-mflogo-font
+                    texlive-palatino
+                    texlive-zapfding))))
       (home-page "https://www.gnu.org/software/teximpatient/")
       (synopsis "Book on TeX, plain TeX and Eplain")
       (description
@@ -11603,8 +11596,6 @@ and Karl Berry.")
            qtbase-5
            qtsvg-5
            zlib))
-    (propagated-inputs
-     (list (texlive-updmap.cfg (list texlive-ec))))
     (native-inputs
      (list python pkg-config))
     (home-page "https://www.lyx.org/")
@@ -13928,13 +13919,9 @@ facilities of @code{tabu} in a modified @code{longtable} environment.")
                  "usepackage[dvips]{xcolor}")))))))
     (native-inputs
      (list (texlive-updmap.cfg
-            (list texlive-ec
-                  texlive-footmisc
+            (list texlive-footmisc
                   texlive-fourier
-                  texlive-graphics-def
                   texlive-hypdoc
-                  texlive-hyperref
-                  texlive-iftex
                   texlive-infwarerr
                   texlive-kvoptions
                   texlive-listings
@@ -13942,7 +13929,6 @@ facilities of @code{tabu} in a modified @code{longtable} environment.")
                   texlive-pgf
                   texlive-pst-text
                   texlive-pstricks
-                  texlive-url
                   texlive-xcolor))))
     (home-page "https://ctan.org/pkg/xkeyval")
     (synopsis "Extension of the @code{keyval} package")