summary refs log tree commit diff
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-12 13:54:53 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:39 +0800
commit7a331818138c7593ad2f73dba34edb6203eb3d16 (patch)
tree03e7ea851446e79d7d18b222ffe09a743e84b1c2
parentdf573464d53f7641db7d82d1d9edd55488811097 (diff)
downloadguix-7a331818138c7593ad2f73dba34edb6203eb3d16.tar.gz
gnu: kpty: Use G-expressions.
* gnu/packages/kde-frameworks.scm (kpty)[arguments]:
Rewrite as G-expressions.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/kde-frameworks.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 46d607de05..43cb2feea8 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1979,13 +1979,13 @@ were traditional plugins.")
            ;; TODO: utempter, for managing UTMP entries
            qtbase-5))
     (arguments
-     `(#:tests? #f ; FIXME: 1/1 tests fail.
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-tests
-           (lambda _
-             (substitute* "autotests/kptyprocesstest.cpp"
-               (("/bin/bash") (which "bash"))))))))
+     (list #:tests? #f ; FIXME: 1/1 tests fail.
+           #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'patch-tests
+                          (lambda _
+                            (substitute* "autotests/kptyprocesstest.cpp"
+                              (("/bin/bash")
+                               (which "bash"))))))))
     (home-page "https://community.kde.org/Frameworks")
     (synopsis "Interfacing with pseudo terminal devices")
     (description "This library provides primitives to interface with pseudo