summary refs log tree commit diff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-09-11 15:18:26 +0200
committerLeo Famulari <leo@famulari.name>2018-10-02 15:46:04 -0400
commit7af2dd38268e8d043352a6f5845cce1ee8f2fe4f (patch)
treeda195dfc950ba1d5b3e35c2993b7cf869be97200
parentf6890c08912c7b2a2b7f6c1cdeda412ff73e0b1d (diff)
downloadguix-7af2dd38268e8d043352a6f5845cce1ee8f2fe4f.tar.gz
gnu: Add r-dvmisc.
gnu/packages/cran.scm (r-dvmisc): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 76c9c734f2..2db310b636 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6082,3 +6082,28 @@ replicating the evaluation as many times as specified, and returning the results
 conveniently wrapped into a data frame.")
     (license license:gpl2+)))
 
+(define-public r-dvmisc
+  (package
+    (name "r-dvmisc")
+    (version "1.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "dvmisc" version))
+       (sha256
+        (base32 "1dy0yykskwhkql19bhzmbwsgv028afc8jh9yqwbczj6f3vpv31zh"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-mass" ,r-mass)
+       ("r-rbenchmark" ,r-rbenchmark)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "https://cran.r-project.org/web/packages/dvmisc/")
+    (synopsis "Faster computation of common statistics and miscellaneous functions")
+    (description
+     "This package implements faster versions of base R functions (e.g. mean, standard
+deviation, covariance, weighted mean), mostly written in C++, along with
+miscellaneous functions for various purposes (e.g. create the histogram with
+fitted probability density function or probability mass function curve, create
+the body mass index groups, assess the linearity assumption in logistic
+regression).")
+    (license license:gpl2)))